Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#43586 - "invalid or corrupted package" - pacman should explicitly say what package is corrupted

Attached to Project: Pacman
Opened by Damian Nowak (Nowaker) - Tuesday, 27 January 2015, 16:10 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 12 December 2018, 05:03 GMT
Task Type Bug Report
Category Output
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Medium
Priority Normal
Reported Version 4.2.0
Due in Version 6.0.0
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Total Installed Size: 1044.97 MiB
Net Upgrade Size: 237.14 MiB

:: Proceed with installation? [Y/n]
(328/328) checking keys in keyring [####################################################] 100%
(328/328) checking package integrity [####################################################] 100%
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.



I probably can use --debug and find which package is corrupted, but that's extremely sub-optimal.

pacman should explicitly say what package(s) are corrupted.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 12 December 2018, 05:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  https://git.archlinux.org/pacman.git/com mit/?id=192d6166e9cb2a8f26d7256690e0158b d5a5d226

Loading...