Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43575 - [kactivities-frameworks] requires systemsettings5 and kcmshell5 to activate plugins

Attached to Project: Arch Linux
Opened by Moabit (Moabit) - Sunday, 25 January 2015, 21:54 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 26 January 2015, 08:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Due to dependencies, kactivities4 has now been replaced by kactivities-frameworks. However, on upgrade, certain plugins (e.g. org.kde.ActivityManager.VirtualDesktopSwitchEnabled) are not enabled by default.

Apparently, users can use systemsettings5 or kcmshell5 to enable these, but these packages are missing in Arch. Otherwise users need to manually edit a config file and run terminal commands. More information here: https://bugs.kde.org/show_bug.cgi?id=336266#c12

kactivities-frameworks 5.6.0-1
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 26 January 2015, 08:28 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See comments
Comment by Antonio Rojas (arojas) - Sunday, 25 January 2015, 21:57 GMT
They are not missing: systemsettings5 is in the systemsettings package, kcmshell5 is in kde-cli-tools
Comment by Moabit (Moabit) - Sunday, 25 January 2015, 22:30 GMT
Ah, apologies. However,
1) Should they be marked as (optional?) dependencies of kactivities-frameworks?
2) I attempted to install systemsettings, but was told that "systemsettings and kdebase-workspace are in conflict." I thought it best not to remove kdebase-workspace.
Comment by Andrea Scarpino (BaSh) - Monday, 26 January 2015, 08:28 GMT
KCM stuff are in System Settings. For KDE4 stuff you have to use systemsettings, while for KF5 stuff you have to use systemsettings5.
I'll report this information in the wiki.

Loading...