Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43568 - [konsole] very bad display with konsolepart4

Attached to Project: Arch Linux
Opened by patrick (potomac) - Sunday, 25 January 2015, 15:36 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 26 January 2015, 08:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Today I did a "pacman -Syu" and I immediatly notice a big problem with the package konsolepart4 (4.14.3-4 -> 4.14.3-5),

the display seems corrupted, and it's very slow when I type letters,

I use KDE4, the default KDE4 theme ( oxygen ) and the french localization,

I tried to delete my ~/.kde4 profile but it doesn't fix the problem,

when I downgrade to konsolepart4 4.14.3-4 then the bug is gone, no problems,

so there is a big problem with konsolepart4 4.14.3-5 package, this version gives an horrible display and there is some lags when I type commands in the console

you can check the screenshot I took, the display is not good



Additional info:
* package version(s) konsolepart4 4.14.3-5, french version of KDE4
* config and/or log files etc.


Steps to reproduce:

-upgrade to konsolepart4 4.14.-5
-
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 26 January 2015, 08:38 GMT
Reason for closing:  Upstream
Additional comments about closing:  See last comment
Comment by patrick (potomac) - Sunday, 25 January 2015, 16:01 GMT
changing the font seems to solve the problem,

the font was initialy set to "monospace normal",

so I set to "courier", then I set again to "monospace" and the bug is gone again, it's very strange,

but I notice always some lags with this version of konsolepart4 when I type commands
Comment by Michael Tunnell (MichaelTunnell) - Sunday, 25 January 2015, 16:06 GMT
I guess we were writing the bug at the same time. :) Yes, the solution for now is to change the font once and back.

https://bugs.archlinux.org/task/43569?project=1&cat[0]=2&string=konsole

I also sent the bug upstream to KDE because I found a Gentoo user who experienced the same problem, https://bugs.kde.org/show_bug.cgi?id=343281
Comment by Michael Tunnell (MichaelTunnell) - Sunday, 25 January 2015, 17:18 GMT
I would suggest possibly not closing this request because it is for a different app even though it is likely sharing the same bug. I am not sure why this is showing on the regular konsole package rather than just the konsolepart4 package.
Comment by patrick (potomac) - Sunday, 25 January 2015, 18:18 GMT
Michael Tunnell : no we talk about the same software : konsole,

I said "konsolepart4" because the problem begins with the upgrade of the konsolepart4 package ( 4.14.3-4 to 4.14.3-5 )

but we talk about the same software: konsole, "konsolepart4" is just a package who brings config files, lib files for konsole
Comment by Ongun Kanat (6ng4n) - Monday, 26 January 2015, 02:04 GMT
In my configuration the intensive fonts have become 'Normal' not 'Bold'. I've also checked 15.04 version of Kubuntu and bug is also there. So it may be a upstream issue. I think KDE SC based on Frameworks 5 is not ready/stable yet. I know it is a rolling-release distro but is it too early to upgrade to new KDE SC.
Comment by Michael Tunnell (MichaelTunnell) - Monday, 26 January 2015, 03:47 GMT
@Ongun I agree and this is why I already submitted it as a bug upstream. https://bugs.kde.org/show_bug.cgi?id=343281
Comment by Ongun Kanat (6ng4n) - Monday, 26 January 2015, 03:58 GMT
@Michael oh, I see. I will upvote it.
Comment by Andrea Scarpino (BaSh) - Monday, 26 January 2015, 08:38 GMT
That is Konsole using KF5, not Konsole from KDE4.

With konsolepart4 4.14.3-4 the old konsole is used, while with konsolepart4 4.14.3-5 the new one is used. The new one have some font rendering issue that have already been reported upstream.

Loading...