Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43424 - [hugin] Broken dependency on libpython2.7.so.1.0

Attached to Project: Arch Linux
Opened by Michal Feix (feixm) - Monday, 12 January 2015, 19:58 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 12 January 2015, 23:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
With Arch installation fully updated, Hugin depends on libpython2.7.so.1.0, even it does not have python2.7 in its dependencies (only in optionals).

Additional info:
Package version: Hugin 2014.0.0-2

Steps to reproduce:

#> pacman -Syu
#> pacman -S hugin
#> hugin
hugin: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 12 January 2015, 23:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  hugin-2014.0.0-3 in [extra]
Comment by Gaetan Bisson (vesath) - Monday, 12 January 2015, 21:14 GMT
It seems libpython2.7.so.1.0 is only used by /usr/lib/hugin/libhugin_python_interface.so.0.0; too bad it does not use dynamic loading...
Comment by Michal Feix (feixm) - Monday, 12 January 2015, 21:50 GMT
On Gentoo Linux, Hugin binary also depends on Python, but libpython3.3.so.1.0. I understand that Python 3 is the default latest version of Python on Arch, so if adding Python into Hugin's dependencies is going to be the solution, I'd rather suggest compiling Hugin against Python 3, rather then Python 2.
Comment by Gaetan Bisson (vesath) - Monday, 12 January 2015, 21:57 GMT
That sounds good. Thanks for the suggestion.

Currently hugin fails to recompile against the new lensfun library. Once I fix this I'll push a new package.

Loading...