Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43405 - [dhcp] unable to start dhcpd6

Attached to Project: Arch Linux
Opened by MichaƂ Zegan (webczat) - Sunday, 11 January 2015, 00:04 GMT
Last edited by Isenmann Daniel (ise) - Monday, 13 July 2015, 21:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Anatol Pomozov (anatolik)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have installed the dhcp package and I want to provide both dhcpv4 and dhcpv6 service on one of my network interfaces.
The dhcpd server, no matter if run in ipv6 or ipv4 mode, by default reads /etc/dhcpd.conf as it's configuration file, but the dhcp server is unable to be started to provide both v4 and v6, you have to start two separate instances.
Now the problem:
If I want to do both v4 and v6 and try to introduce one v4 and one v6 subnet in the dhcpd.conf, starting the v4 server gives an error saying that subnet6 declarations are not allowed, starting in ipv6 mode gives errors about ip/bitmask mismatch.
The only solution is to either have only one (v4 or v6) instance configured, or make 2 config files, one for v4 and one for v6, and then modifying one of the default systemd services to point to a new config file.
I suggest that, as many other distributions have similarly, the default dhcpd4.service should be left intact, but dhcpd6.service should use /etc/dhcpd6.conf instead of /etc/dhcpd.conf to eliminate a need for modifying the service file.
This task depends upon

Closed by  Isenmann Daniel (ise)
Monday, 13 July 2015, 21:12 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of https://bugs.archlinux.org/task/23933?pr oject=1&dev=997

Will be fixed in the next package update
Comment by Isenmann Daniel (ise) - Tuesday, 07 July 2015, 07:19 GMT
Just for information: At the moment I have too little time for Arch, I will do my best to find a solution in the next upcoming weeks.

Loading...