Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43360 - [sage] JMol browser applet not working after SAGE upgrade

Attached to Project: Arch Linux
Opened by Mikkel Bue Lykkegaard (mikkelbue) - Tuesday, 06 January 2015, 18:42 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 07 January 2015, 03:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When I try to run any "parametric_plot3d" from the SAGE notebook interface, I do not get any output, with neither Firefox nor Midori.
If I run the same command from the sage CLI, JMol pops up with the right output.

I am using jre7 and icedtea-web. My icedtea is working fine with other java-applets on the web.

Additional info:
I upgraded sage-mathematics from 6.4.1-1 to 6.4.1-5
Installed sage-notebook 0.11.1-1 and jmol 14.2.9-1
as they are now optional dependencies

for java, I am using:
jre7-openjdk 1.7.0_71
icedtea-web 1.5.2-1

Steps to reproduce:
1. Upgrade sage-mathematics to 6.4.1-5
2. Install sage-notebook 0.11.1-1 and jmol 14.2.9-1
3. Run "sage -n" to open the sage notebook
4. Run any parametric_plot3d (e.g. parametric_plot3d((sin, cos, lambda u: u/10), (0,20)) in the notebook.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 07 January 2015, 03:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  jmol-14.2.9-2
Comment by Antonio Rojas (arojas) - Tuesday, 06 January 2015, 18:59 GMT
Thanks for the report. Fixed in sage-notebook 0.11.1-2
Comment by Mikkel Bue Lykkegaard (mikkelbue) - Tuesday, 06 January 2015, 20:26 GMT
Thanks a lot for the quick response. However, I am still unable to produce any parametric_plot3d output on the notebook, even after the upgrade to sage-notebook 0.11.1-2.
Also, I noticed that the "Use java for 3-D" box unticks automatically every time I refresh the site. I don't know if it is related.
Comment by Antonio Rojas (arojas) - Tuesday, 06 January 2015, 21:04 GMT
Please try jmol-14.2.9-2
Comment by Mikkel Bue Lykkegaard (mikkelbue) - Tuesday, 06 January 2015, 21:21 GMT
That solved it! Thanks a bunch :)

Loading...