Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43341 - [pacman] updpkgsums changes permissions of PKGBUILD to 600

Attached to Project: Arch Linux
Opened by Max Bruckner (FSMaxB) - Monday, 05 January 2015, 11:30 GMT
Last edited by Dave Reisner (falconindy) - Monday, 05 January 2015, 13:20 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
When I run updpkgsums with a PKGBUILD that has permissions 644, it changes them to 600. This is really annoying because when I create a source package from that, it get's refused by the AUR with the error "Error - all files must have permissions of 644 or 755." and I have to change the permissions manually.

Additional info:
* version 4.2.0-5

Possible fixes:
1. save the permissions of the PKGBUILD and then reapply them after the new file got written.
2. always chmod to 644 after the new file got written.
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 05 January 2015, 13:20 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#43272 
Comment by Karol Błażewicz (karol) - Monday, 05 January 2015, 11:51 GMT
Duplicate of  FS#43272  ?

Loading...