Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43319 - [mime-types] [mutt] application/pgp-encrypted breaks sending public keys with extension .asc

Attached to Project: Arch Linux
Opened by Florian (nblock) - Saturday, 03 January 2015, 20:00 GMT
Last edited by Gaetan Bisson (vesath) - Sunday, 18 January 2015, 22:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When sending a public key with the extension .asc using mutt, the receiver only gets an attachment with the content 'Version: 1' and nothing else. The problem is located in /etc/mime.types (from mime-types) as it contains 'application/pgp-encrypted asc pgp'. Mutt uses this mime-type to override the content of the file the hard way as shown in [1].

Possible solution:
* Remove the entry from /etc/mime.types

Additional info:
* mime-types 9-1
* mutt 1.5.23-1

Steps to reproduce:
* Create a public key: gpg --export-options export-minimal -a --export keyid > pubkey.asc
* Open mutt
* Compose a new e-mail
* Attach the created public key file: pubkey.asc
* Mutt detects the mime-type as application/pgp-encrypted and replaces the content with 'Version: 1' [1].

[1] http://sourceforge.net/p/mutt/code/ci/default/tree/sendlib.c#l443
This task depends upon

Closed by  Gaetan Bisson (vesath)
Sunday, 18 January 2015, 22:08 GMT
Reason for closing:  Upstream
Comment by Doug Newgard (Scimmia) - Sunday, 04 January 2015, 02:29 GMT
Sounds to me like a problem with mutt, not with the mime types.
Comment by Johannes Löthberg (demize) - Sunday, 04 January 2015, 02:58 GMT
Yeah, it’s definitely a bug in mutt (which has bitten me in the past), what the hell is that code even trying to do?
Comment by Florian (nblock) - Sunday, 04 January 2015, 08:57 GMT
I forwarded this to mutt: http://dev.mutt.org/trac/ticket/3724
Comment by Florian (nblock) - Saturday, 10 January 2015, 10:43 GMT

Loading...