Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43251 - [kodi] conflicting files from xbmc

Attached to Project: Community Packages
Opened by John (graysky) - Saturday, 27 December 2014, 21:27 GMT
Last edited by Ike Devolder (BlackEagle) - Wednesday, 21 January 2015, 11:46 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Allan McRae (Allan)
Ike Devolder (BlackEagle)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: The following files are identified as in conflict with kodi upon enabling [community-testing] and attempting the install.

kodi: /usr/include/xbmc exists in filesystem
kodi: /usr/lib/xbmc exists in filesystem
kodi: /usr/share/xbmc exists in filesystem

Full output attached.

Additional info:
* package version(s) kodi-14.0-0.5

kodi-14.0-0.5-x86_64 26.9 MiB 3.37M/s 00:08 [############################################] 100%
kodi-14.0-0.5-x86_64.sig 543.0 B 0.00B/s 00:00 [############################################] 100%
loading packages...
resolving dependencies...
looking for inter-conflicts...
:: kodi and xbmc are in conflict. Remove xbmc? [y/N] y

Packages (6): bluez-libs-5.26-1 python2-pybluez-0.20-2 python2-simplejson-3.6.5-1 sdl2-2.0.3-1 xbmc-13.2-6 [removal]
kodi-14.0-0.5

Total Download Size: 0.64 MiB
Total Installed Size: 84.44 MiB
Net Upgrade Size: 8.46 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
bluez-libs-5.26-1-x86_64 65.6 KiB 1311K/s 00:00 [############################################] 100%
sdl2-2.0.3-1-x86_64 456.2 KiB 2.22M/s 00:00 [############################################] 100%
python2-pybluez-0.20-2-x86_64 55.9 KiB 2.37M/s 00:00 [############################################] 100%
python2-simplejson-3.6.5-1-x86_64 81.8 KiB 2.28M/s 00:00 [############################################] 100%
(5/5) checking keys in keyring [############################################] 100%
(4/5) checking package integrity [############################################] 100%
(4/5) loading package files [############################################] 100%
(5/5) checking for file conflicts [############################################] 100%
error: failed to commit transaction (conflicting files)
kodi: /usr/include/xbmc exists in filesystem
kodi: /usr/lib/xbmc exists in filesystem
kodi: /usr/share/xbmc exists in filesystem
Errors occurred, no packages were upgraded.
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Wednesday, 21 January 2015, 11:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  still fixed as it was before
Comment by Johannes Löthberg (demize) - Saturday, 27 December 2014, 21:39 GMT
So which package owns those directories?
Comment by John (graysky) - Saturday, 27 December 2014, 21:44 GMT
I believe the old xbmc but I have manually nuked them, then install the kodi package. Someone else will have to attempt this in chroot or VM.

EDIT: On another box:

% pacman -Qo /usr/include/xbmc /usr/lib/xbmc /usr/share/xbmc
/usr/include/xbmc is owned by xbmc 13.2-6
/usr/lib/xbmc is owned by xbmc 13.2-6
/usr/share/xbmc is owned by xbmc 13.2-6
Comment by Johannes Löthberg (demize) - Saturday, 27 December 2014, 21:46 GMT
And -Syu'ing on that box gives the same issue? If so it’s a pacman bug because the kodi package clearly conflicts with the xbmc package.
Comment by John (graysky) - Saturday, 27 December 2014, 22:16 GMT
Yes. This is on a friend's box:

1. Enable [community-testing] in /etc/pacman.conf
2. % sudo pacman -Syy
3. % sudo pacman -S kodi
resolving dependencies...
looking for inter-conflicts...
:: kodi and xbmc are in conflict. Remove xbmc? [y/N] y

Packages (6): bluez-libs-5.26-1 python2-pybluez-0.20-2 python2-simplejson-3.6.5-1 sdl2-2.0.3-1 xbmc-13.2-6 [removal]
kodi-14.0-0.5

Total Download Size: 27.72 MiB
Total Installed Size: 85.23 MiB
Net Upgrade Size: 8.47 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
bluez-libs-5.26-1-i686 67.5 KiB 577K/s 00:00 [############################################] 100%
sdl2-2.0.3-1-i686 459.7 KiB 3.05M/s 00:00 [############################################] 100%
kodi-14.0-0.5-i686 27.1 MiB 7.06M/s 00:04 [############################################] 100%
python2-pybluez-0.20-2-i686 55.4 KiB 27.1M/s 00:00 [############################################] 100%
python2-simplejson-3.6.5-1-i686 82.9 KiB 27.0M/s 00:00 [############################################] 100%
(5/5) checking keys in keyring [############################################] 100%
(5/5) checking package integrity [############################################] 100%
(5/5) loading package files [############################################] 100%
(5/5) checking for file conflicts [############################################] 100%
error: failed to commit transaction (conflicting files)
kodi: /usr/include/xbmc exists in filesystem
kodi: /usr/lib/xbmc exists in filesystem
kodi: /usr/share/xbmc exists in filesystem
Errors occurred, no packages were upgraded.

No issues if I remove xbmc first (-Rs xbmc) and then install kodi.
Comment by Doug Newgard (Scimmia) - Saturday, 27 December 2014, 23:41 GMT
Seems to be because it's replacing a dir with a symlink, pacman doesn't like doing that. Don't know if this is something that would need fixed in pacman or if it just needs a manual intervention notice.
Comment by Allan McRae (Allan) - Saturday, 27 December 2014, 23:54 GMT
Hrm... you have [community-testing] enabled, but not [testing]? Because this is not an issue with pacman-4.2.
Comment by Allan McRae (Allan) - Sunday, 28 December 2014, 00:02 GMT
Also, fix the .install file. It should not print these message on removal!:

( 6/22) removing kodi [######################] 100%
To autostart xbmc standalone read: https://wiki.archlinux.org/index.php/Xbmc#Autostarting_at_boot

(or update, or at all...)
Comment by Doug Newgard (Scimmia) - Sunday, 28 December 2014, 03:52 GMT
Uh-oh, graysky...are you doing unsupported partial updates?
Comment by Ike Devolder (BlackEagle) - Sunday, 28 December 2014, 07:31 GMT
I can also confirm that it is only an issue with pacman < 4.2

did not test that before
Comment by John (graysky) - Sunday, 28 December 2014, 07:42 GMT
My bad. Yes, I didn't enable [testing] in this case, just [community-testing].
Comment by Robert Meijers (RobertMe) - Thursday, 15 January 2015, 08:16 GMT
  • Field changed: Percent Complete (100% → 0%)
There also occurs an error when you have xbmc-pvr-addons installed:
kodi: /usr/lib/xbmc exists in filesystem
kodi: /usr/share/xbmc exists in filesystem

After manually removing xbmc-pvr-addons the update runs successfully.

Don't know if these are integrated now? Or if there should be a new/updated package which prevents this conflict.
Comment by Ike Devolder (BlackEagle) - Wednesday, 21 January 2015, 11:35 GMT
@RobertMe, kodi-pvr-addons should replace xbmc-pvr-addons automatically
Comment by Ike Devolder (BlackEagle) - Wednesday, 21 January 2015, 11:45 GMT
I just tried this by installing xbmc and xbmc-pvr-addons from arm and had no issues at all:

:: Volledige systeemsupgrade starten...
:: xbmc vervangen met blackeagle-pre-community/kodi? [J/n] j
:: xbmc-pvr-addons vervangen met blackeagle-pre-community/kodi-pvr-addons? [J/n] j

(blackeagle-pre-community is exactly the same package as in community, it is before community so i can test the updates before dropping it in community)

(24/24) beschikbare schijfruimte controleren [###############################################] 100%
(1/2) verwijderen xbmc-pvr-addons [###############################################] 100%
(2/2) verwijderen xbmc [###############################################] 100%
To autostart xbmc standalone read: https://wiki.archlinux.org/index.php/Xbmc#Autostarting_at_boot
( 1/22) upgraden gnutls .....
....
(21/22) installeren kodi [###############################################] 100%
Optionele afhankelijkheden voor kodi
afpfs-ng: Apple shares support
bluez: Blutooth support
libnfs: NFS shares support
libplist: AirPlay support [geïnstalleerd]
libcec: Pulse-Eight USB-CEC adapter support
lirc: Remote controller support
pulseaudio: PulseAudio support [geïnstalleerd]
shairplay: AirPlay support
udisks: Automount external drives
unrar: Archives support [geïnstalleerd]
unzip: Archives support [geïnstalleerd]
upower: Display battery level [geïnstalleerd]
(22/22) installeren kodi-pvr-addons [###############################################] 100%
Optionele afhankelijkheden voor kodi-pvr-addons
tvheadend-git: tvheadend backend
mythtv: mythtv backend

output is in dutch but you get the idea

Loading...