Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43226 - [xf86-video-nouveau] should depend on mesa instead of mesa-dri

Attached to Project: Arch Linux
Opened by Sebastiaan Lokhorst (lonaowna) - Thursday, 25 December 2014, 23:26 GMT
Last edited by Jan de Groot (JGC) - Thursday, 08 October 2015, 07:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Currently, xf86-video-nouveau depends on mesa-dri. This makes the user choose between one of the packages which provide mesa-dri (mesa, mach64-dri, savage-dri, sis-dri, r128-dri, unichrome-dri, mga-dri, tdfx-dri, i810-dri). These are all incompatible with xf86-video-nouveau, except for mesa. It should just depend on mesa.

The same goes for the xf86-video-ati and xf86-video-intel packages.
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 08 October 2015, 07:28 GMT
Reason for closing:  Fixed
Comment by Emil (xexaxo) - Wednesday, 11 March 2015, 19:24 GMT
Imho a more appropriate solution is to revert back to using foo-dri as a dependency, i.e. revert this commit [1].
Although it's up-to the package maintainer to make the call.

[1] https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/xf86-video-nouveau&id=6f96a0802f2f372c97242e3a80c6cf5c61faaf36
Comment by Sebastiaan Lokhorst (lonaowna) - Saturday, 27 June 2015, 17:34 GMT
This is no longer a major issue, as now only mesa provides mesa-dri.

Loading...