Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43203 - [firefox] Missing StartupWMClass in firefox.desktop

Attached to Project: Arch Linux
Opened by Robert Orzanna (orschiro) - Tuesday, 23 December 2014, 09:07 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 14 February 2015, 20:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

'StartupWMClass=Firefox' should be added to firefox.desktop [1] (which I think is provided by the Arch Linux package. Upstream uses the entry already [2]) to prevent multiple icons from showing up in docks such as plank or docky. See this [3] for more information.


[1] https://projects.archlinux.org/svntogit/packages.git/plain/trunk/firefox.desktop?h=packages/firefox

[2] http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/linux/rpm/mozilla.desktop

[3] http://kb.openstudioproject.com/content/fix-double-google-chrome-icon-docky-and-plank
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 14 February 2015, 20:58 GMT
Reason for closing:  Won't implement
Additional comments about closing:  This is caused by a bug in BAMF.
Comment by Robert Orzanna (orschiro) - Saturday, 17 January 2015, 19:55 GMT
The same issue is apparent for Thunderbird [1] and can be solved the same way by adding

StartupWMClass=Thunderbird

to thunderbird.desktop.

Should I open a new bug report for Thunderbird?

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1121932
Comment by Evangelos Foutras (foutrelis) - Wednesday, 28 January 2015, 16:39 GMT
I tested using Plank (on Xfce) and didn't notice any issues with duplicate icons appearing in the dock.

It's also worth noting that Fedora has removed the StartupWMClass property from their .desktop files for Firefox and Thunderbird:

https://bugzilla.redhat.com/show_bug.cgi?id=844860

Are you sure there's an actual issue here? If so, please provide specific steps so we can try to reproduce it.
Comment by Robert Orzanna (orschiro) - Saturday, 31 January 2015, 14:51 GMT
@foutrelis

The linked bug report is from 2012. I assume that the importance of StarupWMClass must have changed since then.

Please note, that the issue with duplicate icons is only evident on an immediate update of Firefox or Thunderbird, without a restart of the user session (e.g. through logout or reboot).
Comment by Evangelos Foutras (foutrelis) - Saturday, 31 January 2015, 18:25 GMT
I was able to get a duplicated Firefox icon after reinstalling the firefox package and restarting Firefox.

This issue, however, only seems to affect Plank; Docky and Cairo-Dock work fine and show just one icon.

Setting StartupWMClass shouldn't be necessary and since other docks work fine, I'd suggest to file a bug with Plank.
Comment by Robert Orzanna (orschiro) - Sunday, 01 February 2015, 13:42 GMT
@foutrelis

Thanks for your help. I filed a report at the Plank Bug Tracker [1].

Regards,

Robert

[1] https://bugs.launchpad.net/plank/+bug/1416837
Comment by Evangelos Foutras (foutrelis) - Sunday, 01 February 2015, 20:15 GMT
After some further investigation, the issue seems to originate from BAMF.

I noticed you have filed a report against BAMF so I marked the Plank one as a duplicate of that:

https://bugs.launchpad.net/bamf/+bug/1393081

I'm going to close this task as "Won't fix" since adding StartupWMClass is an application-specific workaround for the bug in BAMF.

If BAMF gets fixed upstream I will backport any relevant patches. (I subscribed to LP bug #1393081.)

Loading...