Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43202 - [maven] Missing dependency: which

Attached to Project: Community Packages
Opened by Christian Kampka (chris-) - Tuesday, 23 December 2014, 08:42 GMT
Last edited by Sergej Pupykin (sergej) - Friday, 13 February 2015, 16:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The mvn script /usr/bin/mvn requires which to be installed. Without it, the script cannot execute:

mvn clean package
/usr/sbin/mvn: line 143: which: command not found
/usr/sbin/mvn: line 166: which: command not found
Error: JAVA_HOME is not defined correctly.
We cannot execute

This dependency however is not defined in the maven package dependencies.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Friday, 13 February 2015, 16:29 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Tuesday, 23 December 2014, 08:59 GMT
You need to be very careful removing packages that are part of the base group. Some packagers will assume they're installed.
Comment by Christian Kampka (chris-) - Tuesday, 23 December 2014, 09:07 GMT
I did not remove it, I just did not bootstrap the base group as apart of the build chroot that I am using maven in, mainly because I like to make as little assumptions about installed packages as possible.
The reason why this is useful can be seen here.
Comment by Doug Newgard (Scimmia) - Tuesday, 23 December 2014, 09:18 GMT
Removing them or not installing them in the first place is the same thing. My point stands.

Loading...