Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43195 - [wireless-regdb] Regulatory domain is always set to Cyprus (ISO code CY)

Attached to Project: Arch Linux
Opened by Vorbote (vorbote) - Monday, 22 December 2014, 13:12 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 23 December 2014, 16:37 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

No matter what to country I set up the regulatory domain, be it my country of residence or any other country in the world; something in the system forces the regulatory domain to Cyprus (iso code CY) immediately after the udev rule runs and sets the correct settings.

This may or may not be related to  FS#40753 .
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 23 December 2014, 16:37 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Tuesday, 23 December 2014, 08:33 GMT
Check the country settings for your access point. When your client associates, it will override your settings with the settings from the access point.
Comment by Vorbote (vorbote) - Tuesday, 23 December 2014, 11:36 GMT
Sigh! JGC you are right on the money. This AP/DSL bridge was given to me by my ISP, with firmware customized for them by certain Chinese manufacturer that should go nameless (oh wait..., ZTE). The geniuses in Shenzen created a 3-slot offset in the menu so that you need to select the country three places up in the pop-up list (who does a 140 scroll list anyway) to get the right country regulatory domain. Unsuprisingly, the only country name that works when selected is China. Also, it is a good thing I don't live in a country with name starts with a Z.

It wonder why I did not test the AP before. Let's close this. Thanks!!!

Loading...