Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43188 - [systemd] install script should not generate /etc/machine-id

Attached to Project: Arch Linux
Opened by Alain Kalker (ackalker) - Sunday, 21 December 2014, 22:15 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 15 February 2015, 20:31 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

systemd.install's post_install function contains code which generates /etc/machine-id .
As of version 218, systemd ships with systemd-machine-id-commit.service which takes care of creating /etc/machine-id if it doesn't exist, which makes the code in the install script redundant.

As an aside, the way in which the package install script currently generates the machine-id can lead to problems when installing Arch from within KVM or a container, as it doesn't support speciying the machine-id on the command line when creating the VM or container.
The new systemd-machine-id-commit.service is supposed to handle this properly.

Additional info:
* package version(s)
systemd 218-1
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 15 February 2015, 20:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed some time ago (218?)
Comment by Alain Kalker (ackalker) - Sunday, 21 December 2014, 22:25 GMT
On second thought, perhaps it is better to use systemd-machine-id-setup in the install script instead.
Comment by Dave Reisner (falconindy) - Sunday, 21 December 2014, 23:51 GMT
We stopped using systemd-machine-id-setup in the install script because of  FS#40131 . Seems like that's been resolved, so I'm fine switching back to it.

http://cgit.freedesktop.org/systemd/systemd/commit/?id=5dd6d0f8f

Loading...