Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43159 - [open-vm-tools] vmware-user-suid-wrapper depends on gtkmm, but it's not a dependency of the package

Attached to Project: Community Packages
Opened by Peter Dohm (N3rdle) - Friday, 19 December 2014, 07:44 GMT
Last edited by Sergej Pupykin (sergej) - Friday, 13 February 2015, 16:02 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

open-vm-tools' vmware-user-suid-wrapper binary has an undocumented dlload-based dependency upon the gtkmm library. the open-vm-tools package doesn't have a dependency upon the library's package, therefore copy/paste will never work in VMWare guest OSes and it fails silently.

Additional info:
* package version(s)

open-vm-tools 6:9.4.6-3

* config and/or log files etc.

Steps to reproduce:

install open-vm-tools on an arch machine that lacks gtkmm, copy/paste will never work. install gtkmm, it works beautifully :)
This task depends upon

Closed by  Sergej Pupykin (sergej)
Friday, 13 February 2015, 16:02 GMT
Reason for closing:  Not a bug
Comment by Sergej Pupykin (sergej) - Friday, 13 February 2015, 16:01 GMT
gtkmm is in optdep: "gtkmm: DnD/CP plugin"

Loading...