Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43148 - [autojump] autojump broken for zsh users

Attached to Project: Community Packages
Opened by John (graysky) - Thursday, 18 December 2014, 10:18 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 21 February 2016, 15:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

The recent version bump breaks autojump for zsh users. Upon updating, a new shell can be opened but invoking autojump ends in the following error; the only way to recover is to downgrade to


% j
j will not execute and completion _j exists.<shell is hung here until you hit Enter>

zsh: command not found: j


Additional info:
* package version(s) autojump-22.2.2-1

Steps to reproduce:
1. Update and open a new shell (using zsh as your default).
2. Hit j and hit enter.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 21 February 2016, 15:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  Upstream
Comment by John (graysky) - Thursday, 18 December 2014, 10:22 GMT Comment by Jaroslav Lichtblau (Dragonlord) - Thursday, 18 December 2014, 11:34 GMT
Thanks for notifying upstream. I've been following the discussion there.
I've packaged autojump 22.2.2-2
seems to be ok for me.
Comment by Dan Andresan (forumache) - Thursday, 18 December 2014, 12:25 GMT
Jaroslav, I noticed that in -2 you added a post install instructions.
This might not be necessary, as everything which is in /etc/profile.d is sourced automatically (by /etc/profile).
So no need for the user to add the source line to his/her local bashrc.
Comment by Jaroslav Lichtblau (Dragonlord) - Thursday, 18 December 2014, 13:03 GMT
Ah, you're right. I'll remove the install instruction in the next release then again.
Comment by John (graysky) - Thursday, 18 December 2014, 13:33 GMT
For me, 2.22.2-2 does not fix the problem (again, I use zsh as my default shell); if I switch to bash, it works as expected.
Comment by John (graysky) - Thursday, 18 December 2014, 19:47 GMT
EDIT: I see how that my system is somewhat special in that I also have grml-zsh-config installed. In my ~/.zshrc I had to add this line: [[ -f /etc/zsh/zshrc ]] && unalias j

Which together with autojump-22.2.2-2 gives the broken behavior. Can someone else confirm? I can't be the only grml-zsh-config and autojump users out there :p
Comment by Thiago Perrotta (thiagowfx) - Wednesday, 04 March 2015, 18:35 GMT
@graysky I also use grml-zsh-config, but with z-git (in AUR). You might try it as a workaround.

Loading...