Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43138 - [networkmanager-openvpn] Split out cli

Attached to Project: Arch Linux
Opened by giandvd (giandvd) - Wednesday, 17 December 2014, 04:53 GMT
Last edited by freswa (frederik) - Tuesday, 24 March 2020, 19:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Installing networkmanager-openvpn pulls GTK+/GNOME dependencies since it was compiled with GNOME support.

Package should be split into networkmanager-openvpn-cli and networkmanager-openvpn-gnome versions.

Additional info:
* package version(s): 0.9.10.0-1

A /var/abs tree with PKGBUILD files for networkmanager-openvpn-{cli,gnome} is attached.
This task depends upon

Closed by  freswa (frederik)
Tuesday, 24 March 2020, 19:00 GMT
Reason for closing:  None
Additional comments about closing:  This seems pretty stalled to me. If it's still an issue, please fill a re-open request. Thank you :)
Comment by Andrea Scarpino (BaSh) - Wednesday, 17 December 2014, 09:59 GMT
  • Field changed: Summary (networkmanager-openvpn pulls GTK+/GNOME deps → [networkmanager-openvpn] Split out cli)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Ionut Biru (wonder)
I don't consider this a duplicate, since the user here is trying to split the package and not to disable GTK3 support (as the previous one did).
Please Ioni take a look.
Comment by Jan Alexander Steffens (heftig) - Monday, 12 January 2015, 09:57 GMT
How about making it an optdep?
Comment by Andrea Scarpino (BaSh) - Monday, 12 January 2015, 10:03 GMT
Optdep would be nice yes.

Loading...