Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43113 - [cloud-init] Locale configuration broken

Attached to Project: Community Packages
Opened by Troy Engel (TE) - Sunday, 14 December 2014, 16:53 GMT
Last edited by David Runge (dvzrv) - Friday, 07 May 2021, 17:31 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To David Runge (dvzrv)
Christian Rebischke (Shibumi)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The upstream 0.7.6 code (and latest BZR) is broken in locale configuration for Arch; I have filed an upstream bug report and a proposed patch:

https://bugs.launchpad.net/cloud-init/+bug/1402406

I'll attach the same patch here I submitted upstream, however it's quality should be reviewed by a real Python coder.
This task depends upon

Closed by  David Runge (dvzrv)
Friday, 07 May 2021, 17:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with cloud-init 21.2-1
Comment by Doug Newgard (Scimmia) - Wednesday, 26 July 2017, 15:25 GMT
Is this still an issue?
Comment by Alexander E. Patrakov (patrakov) - Friday, 04 September 2020, 21:51 GMT
  • Field changed: Percent Complete (100% → 0%)
Yes it is still an issue, but upstream doesn't respond.
Comment by Troy Engel (TE) - Sunday, 13 September 2020, 12:51 GMT
Happy bug wrangling day! I submitted the bug/patch 2014-12-14 (almost 6yrs ago) and upstream has done nothing. As the submitter I have no vested interested in this bug anymore, we can close it if the Arch team feels it's appropriate.
Comment by Alexander E. Patrakov (patrakov) - Sunday, 13 September 2020, 12:53 GMT
@Troy Engel (TE) you might have lost interest, but I use cloud-init in my Linux trainings, and therefore am interested in a fix for this bug.
Comment by Troy Engel (TE) - Sunday, 13 September 2020, 13:02 GMT
@patrakov Understood, I see you're a Watcher on the upstream issue; I'm not sure if posting a comment on Launchpad helps with this project, you might post a bug comment asking the status to the upstream maintainers?
Comment by Christian Rebischke (Shibumi) - Saturday, 07 November 2020, 09:48 GMT
Any news from upstream? I would really prefer to have this applied upstream.
Comment by Kristian (klausenbusk) - Friday, 29 January 2021, 13:21 GMT Comment by Kristian (klausenbusk) - Monday, 15 March 2021, 19:44 GMT

Loading...