Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43103 - Impossible to install xcursor-vanilla-dmz (file conflict with libxcursor)

Attached to Project: Arch Linux
Opened by ariasuni (Sinma) - Saturday, 13 December 2014, 15:06 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 13 December 2014, 15:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
libxcursor (which is a dependency of xorg) brings files (the cursor Vanilla-DMZ) that conflicts with the installation of xcursor-vanilla-dmz.

Additional info:
* package version(s): libxcursor 1.1.14 and xcursor-vanilla-dmz 0.4.4 (though I think this bug is way older)

Steps to reproduce:
Try to install libxcursor and xcursor-vanilla-dmz at the same time.
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 13 December 2014, 15:39 GMT
Reason for closing:  Not a bug
Additional comments about closing:  /usr/share can't be supported for site-local or user-specific configuration.
Comment by Karol Błażewicz (karol) - Saturday, 13 December 2014, 15:26 GMT
Cannot reproduce. I have them both installed:
$ pacman -Q xcursor-vanilla-dmz libxcursor
xcursor-vanilla-dmz 0.4.4-1
libxcursor 1.1.14-2

Works for me on my 32-bit Arch with [testing] repos enabled.
What exactly is the error message?
Comment by ariasuni (Sinma) - Saturday, 13 December 2014, 15:36 GMT
I understand the issue. The package xcursor-vanilla-dmz has a file at `/usr/share/icons/default/index.theme` but I’ve already symlinked the `/usr/share/icons/default/` directory to `/usr/share/icons/Vanilla-DMZ/`, so the packages manager tries to write on it…

Is it still considered to be a bug? (because it means I need to edit the symlink each time the package is updated)
Comment by Dave Reisner (falconindy) - Saturday, 13 December 2014, 15:38 GMT
No, it's not a bug. You should never be modifying /usr/share. You can instead use $HOME/.Xresources or $HOME/.icons/default.

Loading...