Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43039 - [xf86-video-intel] Xorg with intel driver deterministic crash

Attached to Project: Arch Linux
Opened by Henrique (hdante) - Sunday, 07 December 2014, 20:22 GMT
Last edited by Laurent Carlier (lordheavy) - Monday, 16 February 2015, 20:33 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I'm experiencing crashes with up-to-date arch linux instalation on new notebook. Currently, I'm able to consistently reproduce the crash by opening gnome-terminal, executing top, then pressing F11 to enter full screen mode.

Following the hint on Arch Wiki, disabling "DRI" on Xorg configuration files makes the crash disappear.

cat 20-intel.conf
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "DRI" "False"
EndSection

I'm afraid, however, backtrace is broken:

(...)
Dez 07 17:59:12 dragonmount sudo[2489]: pam_unix(sudo:session): session opened for user root by hdante(uid=0)
Dez 07 17:59:40 dragonmount sudo[2489]: pam_unix(sudo:session): session closed for user root
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE)
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE) Backtrace:
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE) 0: /usr/bin/Xorg.bin (xorg_backtrace+0x56) [0x593d36]
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE) 1: /usr/bin/Xorg.bin (0x400000+0x197e89) [0x597e89]
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE) 2: /usr/lib/libc.so.6 (0x7fb2b2b94000+0x33b20) [0x7fb2b2bc7b20]
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE)
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE) Segmentation fault at address 0x0
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE)
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: Fatal server error:
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE) Caught signal 11 (Segmentation fault). Server aborting
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE)
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE)
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: Please consult the The X.Org Foundation support
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: at http://wiki.x.org
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: for help.
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE) Please also check the log file at "/dev/null" for additional information.
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE)
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (II) AIGLX: Suspending AIGLX clients for VT switch
Dez 07 17:59:47 dragonmount gdm-Xorg-:1[1877]: (EE) Server terminated with error (1). Closing log file.
Dez 07 17:59:48 dragonmount org.a11y.atspi.Registry[2048]: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":1"
Dez 07 17:59:48 dragonmount org.a11y.atspi.Registry[2048]: after 201 requests (201 known processed) with 0 events remaining.
Dez 07 17:59:48 dragonmount gnome-session[2021]: (gnome-shell:2107): Gdk-WARNING **: gnome-shell: Fatal IO error 0 (Sucesso) on X server :1.
(...)

Additional info:
* package version(s)
xorg-server 1.16.2-1
xf86-video-intel 2.99.916-3
mesa 10.3.4-1


* config and/or log files etc.
lspci -vv attached
journalctl -b attached


Steps to reproduce:
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Monday, 16 February 2015, 20:33 GMT
Reason for closing:  Fixed
Comment by Karol Błażewicz (karol) - Sunday, 07 December 2014, 20:57 GMT
Does it happen with UXA acceleration method?
https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues
Comment by Henrique (hdante) - Sunday, 07 December 2014, 21:23 GMT
No, only with SNA. There were no errors with neither UXA nor glamor. I'm pasting here all the configurations that avoid the problem:

-(DRI off)-------------------------
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "DRI" "False"
EndSection
-(no accel)------------------------
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "NoAccel" "True"
EndSection
-(accel method glamor)-------------
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "glamor"
EndSection
-(accel method uxa)----------------
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection
Comment by Henrique (hdante) - Sunday, 11 January 2015, 19:23 GMT
Any updates about this bug ?
Comment by Henrique (hdante) - Monday, 16 February 2015, 20:20 GMT
Hello, I think this bug disappeared, either after some system upgrade, or after I installed more packages. I can't reproduce it anymore.

Loading...