Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43015 - [samba] cannot connect to samba shared files after 4.1.14-1 upgrade

Attached to Project: Arch Linux
Opened by Alfredo Amatriain (amatriain) - Friday, 05 December 2014, 09:11 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 18 December 2014, 11:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

After upgrading samba and smbclient packages from 4.1.13-1 to 4.1.14-1, I can no longer connect to a samba file server.

I've dropped and recreated the samba user with pdbedit to make sure it's not a problem with the user or password. I've also made sure that ports 445 and 139 are open in the firewall. I've checked with an android cifs client to make sure that the issue is with the server, not the client.

Automounting with autofs stopped working. Trying to access a shared folder with Caja using gvfs opens a dialog asking for credentials. Entering the correct user/password/domain just makes the dialog appear again, instead of opening the folder.

"smbclient -L " correctly lists the shared folder, but when trying to mount it with "mount -t cifs" I get an error:

-----------------
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
-----------------

which if I'm not mistaken means that the credentials I passed have been rejected.

After downgrading both samba and smbclient packages back to 4.1.13-1 version, everything works again.

I haven't found anything relevant in the logs.

Another user has confirmed being affected by this. He receives the following error when trying to connect:

----------------
Could not connect to machine 127.0.0.1: NT_STATUS_LOGON_FAILURE
----------------

He also confirms that 4.13.1-1 worked fine for him.

Originally reported in the forums: https://bbs.archlinux.org/viewtopic.php?id=190592
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 18 December 2014, 11:34 GMT
Reason for closing:  Upstream
Comment by John K. (NeK) - Friday, 05 December 2014, 13:40 GMT
I have the same problem. In my debugging attempt I saw this error when I was trying to login (despite that the user existed):

NT_STATUS_NO_SUCH_USER

Maybe it will help in fixing this.

4.1.13 version works great.
Comment by Outshined (Outshined) - Sunday, 14 December 2014, 16:14 GMT
Ran into this - but it seemed to be authenticating but failing on 'tree connect'. Added "sec=ntlmv2" to the options allowed mounting again.
Comment by Jordan Pryde (prydom) - Monday, 15 December 2014, 00:16 GMT
See https://bbs.archlinux.org/viewtopic.php?pid=1484501#p1484501 for some log comparisons between 4.1.13 and 4.1.14 taken moments apart and some cursory debugging. The problem is not so easily worked around for windows clients.

EDIT: Looked at the upstream patch found at "http://samba.org/samba/ftp/patches/patch-4.1.13-4.1.14.diffs.gz" and found that they changed how the "smb_my_netbios_names" array is allocated in "samba-4.1.14/source3/lib/util_names.c" and must have broke "is_myname(cstring)". It's an upstream bug for sure.

EDIT2: Super simple workaround! Just shorten your NETBIOS name by adding "netbios name=[15 chars or less, simple ASCII chars only]" to your smb.conf.

EDIT3: Reported upstream: https://bugzilla.samba.org/show_bug.cgi?id=11008

Loading...