Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43004 - [gedit-plugins] Missing dependency on python-cairo

Attached to Project: Community Packages
Opened by Alex Petrov (root-oog) - Thursday, 04 December 2014, 11:23 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 19 April 2015, 15:27 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ionut Biru (wonder)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
It is need to be set python-cairo as dependency of gedit-plugins. If not then when you try to close one of file tab with active multi-edit plugin (maybe still some) gedit segfault with follow errors:
"TypeError: Couldn't find foreign struct converter for 'cairo.Context'"
"Fatal Python error: unexpected exception during garbage collection"

For now it is only python-dbus-1.2.0-4 and python-dbus-common-1.2.0-4 as gedit-plugin dependency.

Additional info:
gedit-plugins-3.14.1-1

Steps to reproduce:
Install clean gedit and gedit-plugins.
Activate multi-edit plugin.
Open two files and try to close one of them.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 19 April 2015, 15:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  gedit-plugins 3.16.0-2
Comment by Alexander F. Rødseth (xyproto) - Thursday, 22 January 2015, 11:14 GMT
Why was this assigned to Jan Steffens (heftig), Jan de Groot (JGC) and Ionut Biru (wonder)?

Misread as geany-plugins. My bad.

Loading...