Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42944 - [systemd] coredumpctl crashes on dump/gdb

Attached to Project: Arch Linux
Opened by Olivier Brunel (jjacky) - Friday, 28 November 2014, 18:13 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 29 November 2014, 00:02 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When trying to use coredumpctl with either dump or gdb as action, it will crash. From what I've been able to figure out, I'm guessing it's a crash whenever save_core() is called and is related to lz4 compression, the compression used for cores by default.

In fact, downgrading to lz4-123 does fix the issue for me, and when compiling systemd myself (with latest lz4-124) I couldn't reproduce the coredumpctl crash.

I'm not sure why/what actually causes the issue, but it seems that a recompile of systemd w/ lz4-124 (as I believe it was compiled with 123) might fix it.

--
As a side note: systemd's PKGBUILD has options=('debug' 'strip'), does that mean there's a package systemd-debug available somewhere?
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 29 November 2014, 00:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  To be continued with upstream lz4...
Comment by Dave Reisner (falconindy) - Friday, 28 November 2014, 18:30 GMT Comment by Dave Reisner (falconindy) - Friday, 28 November 2014, 23:57 GMT
This is fixed with -8 in [testing], and I've opened a bug about the lz4 borkage:

https://code.google.com/p/lz4/issues/detail?id=147

Loading...