Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42924 - [nvidia-340xx] 340.58-x Cannot find libglx.so

Attached to Project: Arch Linux
Opened by Riccardo Quercetti (elQuero) - Thursday, 27 November 2014, 10:30 GMT
Last edited by Felix Yan (felixonmars) - Monday, 22 December 2014, 00:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: after installing the nvidia-340xx package and its dependencies, there is a wrong symlink that prevent the desktop enviroment start correctly, as you can se in this log:
<pre><code>grep "(EE)" Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 24.855] (EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so: /usr/lib/xorg/modules/extensions/libglx.so: cannot open shared object file: No such file or directory
[ 24.855] (EE) Failed to load module "glx" (loader failed, 7)
[ 24.869] (EE) Failed to load module "nouveau" (module does not exist, 0)
[ 24.869] (EE) Failed to load module "nv" (module does not exist, 0)
[ 24.869] (EE) Failed to load module "modesetting" (module does not exist, 0)
[ 24.869] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 24.870] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 24.878] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[ 24.878] (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
[ 24.878] (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
[ 24.878] (EE) NVIDIA(0): you continue to encounter problems, Please try
[ 24.878] (EE) NVIDIA(0): reinstalling the NVIDIA driver.
</code></pre>
NVidia 340.58 drivers package downloaded from NVidia official website work like a charm.

Additional info:
* package version(s): 340.58-x


Steps to reproduce:
* install nvidia-340xx;
* remove nouveau;
* launch desktop environment.
This task depends upon

Closed by  Felix Yan (felixonmars)
Monday, 22 December 2014, 00:49 GMT
Reason for closing:  Fixed
Comment by Alexander Schnaidt (Namarrgon) - Thursday, 27 November 2014, 15:45 GMT
Do you have the libgl package installed that matches the 'nvidia-340xx' legacy-package i.e. 'nvidia-libgl-340xx'? Or just 'nvidia-libgl'?

On a side-note, don't use the installer from the nvidia-website, it will mess with the filesystem in such ways that the real issue will be even harder to diagnose.
Comment by Riccardo Quercetti (elQuero) - Thursday, 27 November 2014, 21:40 GMT
Hi,
well I think that I've the nvidia-340xx legacy package installed, because I've installed it via this command:
pacman -S nvidia-340xx

The arch installation where I tried the nvidia installer has been binned, I'm using a fresh arch-base with DM installation.

I'll explain the problem: I tried to follow the guide on the wiki for installing nvidia drivers, but when I try to launch Xorg it fails. In its log I've found what can you see in the first post, so I listed the content of the folder specified in the log and this is what I get:
lrwxrwxrwx 1 quero users 16 Nov 15 18:18 libglx.so -> libglx.so.343.22
lrwxrwxrwx 1 quero users 16 Nov 15 18:18 libglx.so.1 -> libglx.so.343.22
lrwxrwxrwx 1 quero users 56 Nov 15 18:18 libglx.so.343.22 -> /usr/lib/nvidia/xorg/modules/extensions/libglx.so.343.22
-rwxr-xr-x 1 quero users 286112 Nov 15 18:18 libglx.xorg

Obviously there isn't any libglx.so.343.22 in /usr/lib/nvidia/[...], but there is a libglx.so.340.58. But fixing the link gave me this Xorg errors:
[ 14.289] (EE) Failed to load module "nouveau" (module does not exist, 0)
[ 14.289] (EE) Failed to load module "nv" (module does not exist, 0)
[ 14.290] (EE) Failed to load module "modesetting" (module does not exist, 0)
[ 14.290] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 14.290] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 16.190] (EE) Server terminated successfully (0). Closing log file.

I hope it will be usefull ;-)
Comment by Alexander Schnaidt (Namarrgon) - Thursday, 27 November 2014, 22:39 GMT
You have to have matching nvidia packages installed; 'nvidia-340xx', 'nvidia-340xx-libgl' and 'nvidia-340xx-utils' are a set and you cannot mix and match with the mainline 'nvidia' or the other legacy 'nvidia-304xx' sets.
Comment by Riccardo Quercetti (elQuero) - Friday, 28 November 2014, 07:58 GMT
Wow, I found that I had the wrong nvidia libgl. So I removed anything related to nvidia and re-issued this command:
pacman -S nvidia-340xx
resolving dependencies...
looking for inter-conflicts...

Packages (3): nvidia-340xx-utils-340.58-1 nvidia-libgl-343.22-1 nvidia-340xx-340.58-2

Total Installed Size: 131.70 MiB

Why is nvidia-libgl-343.22-1 listed as dependency instead of nvidia-libgl-340.58?
Comment by Johan R (cleanrock) - Saturday, 29 November 2014, 09:25 GMT
Probably because of this change:
https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/nvidia-340xx&id=84b4360331830002e200dcc2620d30a323141aba
I suspect maintainer should have kept nvidia-340xx-libgl as a dep.
Comment by Felix Yan (felixonmars) - Saturday, 13 December 2014, 15:25 GMT
Updated, please test with nvidia-340xx 340.65-3.
Comment by User (user5467) - Saturday, 13 December 2014, 15:45 GMT
@Felix Yan nvidia-340xx 340.65-3 works for me. (I wrote that email about nvidia-libg btw) i3 seems to ignore part of its config file, but I don't think that's an issue with the driver.

Loading...