Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42802 - [cups] Unable to enable cups systemd service

Attached to Project: Arch Linux
Opened by Charles Bos (Chazza) - Saturday, 15 November 2014, 20:45 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 16 November 2014, 00:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

With cups 2.0.1-1 issuing:
# systemctl enable cups
returns:
Failed to execute operation: No such file or directory

I tried downgrading to 2.0.0 but that didn't resolve the problem. I had to downgrade to 1.7.5 in order to enable the systemd service.

Can anyone else confirm this? Would it have something to do with the removal of the following patch: https://projects.archlinux.org/svntogit/packages.git/diff/trunk/cups-systemd-socket.patch?h=packages/cups&id=93fcc4e8972adb1274f030acda8e02d62ee7288d
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 16 November 2014, 00:35 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Sunday, 16 November 2014, 00:35 GMT
You didn't read the output of pacman when you did the upgrade, did you?

Loading...