Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42796 - [tigervnc][fltk] fltk 1.3.3-1 breaks control keys within vnc-sessions.

Attached to Project: Community Packages
Opened by John (graysky) - Saturday, 15 November 2014, 11:40 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 24 November 2014, 17:26 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Eric Belanger (Snowman)
Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

The 1.3.3-1 release breaks any combination of ctrl + another key when connected to a tigervnc server. Downgrading to 1.3.2-5 fixes the problem. Not sure if this is an upstream regression or something patch we are not applying.


Additional info:
* package version(s) fltk 1.3.3-1

Steps to reproduce:
1) Install tigervnc and a DE ... on my box it runs lxde.
2) My ~/.vnc/xstartup contains online 1 line: exec startlxde and is started with this command: vncserver -geometry 1792x1008 -alwaysshared
3) Connect to the vncserver and try to ctrl+f or ctrl+t in chromium for example. Nothing happens.

Now downgrade fltk and restart the vncserver. The ctrl+x combinations work as expected.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 24 November 2014, 17:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  thanks
Comment by John (graysky) - Saturday, 15 November 2014, 11:43 GMT Comment by U (Gusar) - Saturday, 15 November 2014, 14:50 GMT
@graysky: It's related for sure. I have no idea how many of those patches listed in  FS#36186  are part of the 1.3.3 release. It seems not all of them are, so dropping the tigervnc patch entirely was not the right way to go, a new tigervnc patch will need to be created. Or Arch packages a SVN snapshot of fltk, that would work too.
Comment by John (graysky) - Thursday, 20 November 2014, 10:09 GMT
  • Field changed: Percent Complete (100% → 0%)
Please reopen since  FS#42795  is about segfaults not this issue.
Comment by U (Gusar) - Thursday, 20 November 2014, 18:35 GMT
Going by this comment[1], it seems packaging a SVN snapshot would not fix the issue, tigervnc-1.3.1 and fltk-1.3.3+ are simply an incompatible combination. The only viable solution appears to be tigervnc-1.4.0, a beta of which was just released.

[1] https://github.com/TigerVNC/tigervnc/issues/72#issuecomment-63786427
Comment by John (graysky) - Thursday, 20 November 2014, 20:36 GMT
I reported this upstream: http://www.fltk.org/str.php?L3155
Comment by John (graysky) - Thursday, 20 November 2014, 20:45 GMT
Using this beta of tigervnc and using the current version of flkt now. No problems with ctrl+x now! Recommend users experiencing the bug update to this beta to resolve the issue. Cannot comment on the stability of the beta version as I have just installed it myself.

PKGBUILD: https://gist.github.com/graysky2/b834c6d3d8fe7db70e3b
Comment by Robot Anarchy (robotanarchy) - Thursday, 20 November 2014, 23:14 GMT
Nice!

@Snowman: Can we ship that beta of tigervnc with arch (put it in testing for a few days, and then release it as 'stable', if everything works out)?

EDIT: Good news seems to be, that we wouldn't need to patch fltk anymore (Gusar already posted the related link):

"The keyboard handling is a messy area. We rely on a lot of patches for FLTK 1.3.2 to get things right. All of them are included in FLTK 1.3.3, but unfortunately some things changed a bit. Meaning that TigerVNC 1.3.1 and FLTK 1.3.3 won't get a fully functional keyboard. TigerVNC 1.4.0 should work fine though, so please test the beta we just released." - https://github.com/TigerVNC/tigervnc/issues/72#issuecomment-63786427
Comment by U (Gusar) - Friday, 21 November 2014, 01:06 GMT
If Arch is going to ship the beta, use the attached PKGBUILD, graysky's has a small issue, it doesn't apply two patches that are still needed. Patching fltk might still be needed though, not for this issue, but for  FS#42795  (the crasher bug).
   PKGBUILD (2.5 KiB)
Comment by John (graysky) - Friday, 21 November 2014, 01:16 GMT
@Gusar - Pretty sure those didn't apply when I tried. I basically took the ARCH PKGBUILD and commented out them 1-by-1.
Comment by Eric Belanger (Snowman) - Friday, 21 November 2014, 04:01 GMT
@robotanarchy: I've assigned tigervnc's maintainer to this bug. I'll let hime handle the tigervnc update.
Comment by U (Gusar) - Friday, 21 November 2014, 11:14 GMT
@graysky: The getmaster patch applies with offsets, but those aren't critical. The gethomedir patch applies cleanly. They're both needed for the libvnc.so module to work properly.

@sergej: Some notes about the PKGBUILD: I added mesa-dri as a dependency - Xvnc uses swrast_dri.so, which nowadays is part of the mesa-dri package. Then, xorg116 and xserver116 patches can be dropped - the former isn't required anymore, the latter is part of the upstream source, so we don't need to ship it ourselves. The PKGBUILD is modified accordingly.

Edit: Hmm, now that I think about it, both mesa-dri and libgl could be optdepends - if they're not around, Xvnc simply won't have opengl available, but it'll still work. I'm attaching a PKGBUILD that does this.
   PKGBUILD (2.5 KiB)
Comment by John (graysky) - Friday, 21 November 2014, 20:30 GMT
I stand corrected, only the xorg patch is no longer needed (xorg116.patch). I updated my PKGBUILD via my link.
Comment by John (graysky) - Monday, 24 November 2014, 13:45 GMT
Been running it 24/7 for 3 days without issue...

Loading...