Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42762 - [pacman] pacman-key broken with latest gnupg

Attached to Project: Arch Linux
Opened by Tobias Powalowski (tpowa) - Wednesday, 12 November 2014, 16:37 GMT
Last edited by Allan McRae (Allan) - Friday, 21 November 2014, 11:23 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Dan McGee (toofishes)
Allan McRae (Allan)
Gaetan Bisson (vesath)
Dave Reisner (falconindy)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Latest gnupg break, pacman-key --init
It does not allow empty passphrases anymore.

We need %no-protection in line 323 to fix this issue.
http://blog.gmane.org/gmane.comp.encryption.gpg.user/day=20141111

Install media will not work anymore when this will move to [core] until this is fixed.


This task depends upon

Closed by  Allan McRae (Allan)
Friday, 21 November 2014, 11:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.1.2-7
Comment by Allan McRae (Allan) - Wednesday, 12 November 2014, 21:25 GMT
That link is useless for details...
Comment by Tobias Powalowski (tpowa) - Thursday, 13 November 2014, 05:24 GMT
Allan it links to a discussion, with exactly the same error you encounter when you run pacman-key --init on a fresh system.
gpg: agent_genkey failed: No pinentry
Comment by Tobias Powalowski (tpowa) - Thursday, 13 November 2014, 07:20 GMT
Patch which adds no-protection line.
Comment by Gaetan Bisson (vesath) - Wednesday, 19 November 2014, 22:37 GMT
Allan, do you mind if I apply Tobias' patch and release an updated pacman package in [testing]?
Comment by Allan McRae (Allan) - Friday, 21 November 2014, 11:23 GMT
pacman-4.1.2-7 in [testing]

Loading...