Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42747 - [chromium] HD webcam input shows green screen

Attached to Project: Arch Linux
Opened by Sebastiaan Lokhorst (lonaowna) - Tuesday, 11 November 2014, 18:21 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 12 November 2014, 17:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to use my webcam for video input in Chromium, for instance when making a Google Hangouts video call, my video input is a completely green screen.
This is likely caused by something going wrong with libyuv, which is in Chromium for HD video input. SD video input works fine, and the webcam works fine in other capture applications.

This issue is NOT present in the pre-compiled Google Chrome, nor on Chromium on Ubuntu. It is present however in Gentoo.

On Arch, the bug has been confirmed with multiple webcams and multiple versions of Chromium, at least v35-39.

There is a very elaborate upstream bug report[1], but we could not figure it out yet. Maybe people who have more knowledge about the Arch-specific build process and libraries, can figure out what is wrong.

[1] https://code.google.com/p/chromium/issues/detail?id=399939
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 12 November 2014, 17:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  libjpeg-turbo 1.3.1-2
Comment by Evangelos Foutras (foutrelis) - Wednesday, 12 November 2014, 03:44 GMT
Please test if the following package has this issue:

http://pkgbuild.com/~foutrelis/test-builds/chromium-bundled-libjpeg/

(It uses the bundled libjpeg instead of linking to the system libjpeg-turbo.)
Comment by Sebastiaan Lokhorst (lonaowna) - Wednesday, 12 November 2014, 06:28 GMT
Wow, that is quick! It works, thank you!!

I will report this in the upstream bug and ask the people there to test it too.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 12 November 2014, 15:33 GMT
Please confirm that the issue is fixed with libjpeg-turbo 1.3.1-2.

(Make sure to reinstall Chromium from the Arch repos before testing.)
Comment by Sebastiaan Lokhorst (lonaowna) - Wednesday, 12 November 2014, 17:26 GMT
I can confirm the the issue is completely gone with libjpeg-turbo 1.3.1-2 and the latest chromium package from the official repositories. Everything works!
Thanks so much for the quick response and fix!
Comment by Evangelos Foutras (foutrelis) - Wednesday, 12 November 2014, 17:36 GMT
No problem, thanks for reporting the issue here. :)

Loading...