Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42668 - systemd 217 can lead to missing /run/xxx

Attached to Project: Arch Linux
Opened by Gene (GeneC) - Monday, 03 November 2014, 16:58 GMT
Last edited by Dave Reisner (falconindy) - Monday, 03 November 2014, 17:00 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: systemd 217 can lead to /run/xxx being missing for some services which do not start properly due to missing /run/xxx


Additional info:
Symptom is that
systemctl status systemd-tmpfiles-setup
does not run cleanly on boot.

In addition journal has messages typified by:

Breaking ordering cycle by deleting job systemd-tmpfiles-setup.service/start
Job systemd-tmpfiles-setup.service/start deleted to break ordering cycle starting with basic.target/start

Discussed on arch-general:
https://lists.archlinux.org/pipermail/arch-general/2014-November/037700.html

Bug fix upstream seems to be this one:

http://cgit.freedesktop.org/systemd/systemd/commit/?id=919699ec301ea507edce4a619141ed22e789ac0d

I found core symptom went away after patching the unit file as shown in the diff above.
N.B. I did not recompile systemd package with the C code patch to nspawn.c


* package version(s) 217-3
* config and/or log files etc.


Steps to reproduce: Boot
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 03 November 2014, 17:00 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#42633 

Loading...