Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42662 - [firefox] xpdf plugin freezes firefox

Attached to Project: Arch Linux
Opened by Matthias Krüger (matthiaskrgr) - Monday, 03 November 2014, 08:24 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 06 November 2014, 00:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I display a pdf inside firefox with this xpdf plugin, attempting to select text inside the pdf freezes firefox apparently, I can also not unselect the firefox window, it's like my cursor is eaten.
The only way to get out is to switch to tty and manually kill xpdf which makes firefox usable again (but also shuts down the pdf viewer).

firefox 33.0.2-1
xpdf 3.04-2
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 06 November 2014, 00:43 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 03 November 2014, 13:54 GMT
Sounds like a problem with the plugin, where is it from?
Comment by Doug Newgard (Scimmia) - Thursday, 06 November 2014, 00:23 GMT
I just built xpdf from the AUR, it doesn't even contain a mozilla plugin. Even if it did, this doesn't seem to be an issue with a supported package. Any reason to keep this open?
Comment by Matthias Krüger (matthiaskrgr) - Thursday, 06 November 2014, 00:30 GMT
Ok, it seemed like firefox managed to open xpdf inside itself and display the pdf through it (altough I told to use MozPlugger based plugin). I had totally forgotten that xpdf is in AUR, sorry for that...

Loading...