Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42648 - [gparted] can't read f2fs partition

Attached to Project: Arch Linux
Opened by mattia (nTia89) - Saturday, 01 November 2014, 12:51 GMT
Last edited by Giovanni Scafora (giovanni) - Sunday, 19 April 2015, 13:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
gparted can't read f2fs partitions, even if gparted has created it!
in the information window of the f2fs partition I get the report:

"Unable to read the contents of this file system!
Because of this some operations may be unavailable.
The cause might be a missing software package.
The following list of software packages is required for f2fs file system support: f2fs-tools."

Additional info:
* gparted-0.20.0-1
* f2fs-tools-1.4.0

Steps to reproduce:
* create a f2fs partition
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Sunday, 19 April 2015, 13:33 GMT
Reason for closing:  Upstream
Comment by mattia (nTia89) - Monday, 02 March 2015, 17:21 GMT
  • Field changed: Percent Complete (100% → 0%)
same problem with today's packages
Comment by Giovanni Scafora (giovanni) - Sunday, 29 March 2015, 08:18 GMT
Have you tried to install f2fs-tools package?
Comment by mattia (nTia89) - Sunday, 29 March 2015, 08:52 GMT
I tried again today.
Latest software installed.
Same issue.

ANYWAY I think I find the trouble: gparted show me this warning ONLY if the f2fs partition is unmounted.
Infact if gparted scans available devices and partitions while f2fs partition is mounted, gparted shows me no warning

For this reason I filed a new bug in gparted bugtracker and I request the closure of this one

Loading...