Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42641 - [xorg-server] X crashes on various activities

Attached to Project: Arch Linux
Opened by brent saner (sanerb) - Friday, 31 October 2014, 23:59 GMT
Last edited by Laurent Carlier (lordheavy) - Wednesday, 15 July 2015, 16:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I hate to be so vague, but I'm still trying to pin down the specifics. Suggestions for output to attach would be welcome.

This is... a weird one.

When:

[0] visiting https://www.kernel.org/category/releases.html in firefox
[1] viewing mysql output in gnome-terminal
[2] using ncurses (e.g. iptraf-ng, airodump-ng, make nconfig, etc.) in gnome-terminal

the following occurs:

[0] Gnome *always* crashes. gdm spawns new session.
[1] Gnome *sometimes* crashes. gdm spawns new session.
[2] Gnome *frequently* crashes. gdm spawns new session.


Additional info:

Yeah, I have no idea what logs to include. I did grab these few promising outputs from dmesg:

[56210.989439] radeon 0000:01:00.0: couldn't schedule ib
[56210.991442] radeon 0000:01:00.0: couldn't schedule ib
[56210.994316] radeon 0000:01:00.0: couldn't schedule ib
[56211.694908] [drm] probing gen 2 caps for device 8086:151 = 261ad03/e
[56211.694915] [drm] enabling PCIE gen 3 link speeds, disable with radeon.pcie_gen2=0
[56212.699016] [drm] PCIE GART of 1024M enabled (table at 0x0000000000276000).
[56212.699132] radeon 0000:01:00.0: WB enabled
[56212.699134] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xffff8800c792ac00
[56212.699136] radeon 0000:01:00.0: fence driver on ring 1 use gpu addr 0x0000000040000c04 and cpu addr 0xffff8800c792ac04
[56212.699137] radeon 0000:01:00.0: fence driver on ring 2 use gpu addr 0x0000000040000c08 and cpu addr 0xffff8800c792ac08
[56212.699138] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0xffff8800c792ac0c
[56212.699140] radeon 0000:01:00.0: fence driver on ring 4 use gpu addr 0x0000000040000c10 and cpu addr 0xffff8800c792ac10
[56212.699909] radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc900061b5a18
[56212.845201] [drm] ring test on 0 succeeded in 2 usecs
[56212.845204] [drm] ring test on 1 succeeded in 1 usecs
[56212.845208] [drm] ring test on 2 succeeded in 1 usecs
[56212.845266] [drm] ring test on 3 succeeded in 2 usecs
[56212.845272] [drm] ring test on 4 succeeded in 1 usecs
[56213.032494] [drm] ring test on 5 succeeded in 2 usecs
[56213.032499] [drm] UVD initialized successfully.
[56213.032544] [drm] ib test on ring 0 succeeded in 0 usecs
[56213.032567] [drm] ib test on ring 1 succeeded in 0 usecs
[56213.032587] [drm] ib test on ring 2 succeeded in 0 usecs
[56213.032608] [drm] ib test on ring 3 succeeded in 0 usecs
[56213.032628] [drm] ib test on ring 4 succeeded in 0 usecs
[56213.184582] [drm] ib test on ring 5 succeeded

and journalctl:

Oct 31 19:31:59 workhorse kernel: radeon 0000:01:00.0: couldn't schedule ib
Oct 31 19:31:59 workhorse kernel: radeon 0000:01:00.0: couldn't schedule ib
Oct 31 19:31:59 workhorse kernel: radeon 0000:01:00.0: couldn't schedule ib
Oct 31 19:31:59 workhorse gnome-keyring-daemon[11632]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Oct 31 19:31:59 workhorse colord[410]: Automatic remove of icc-5ca0354f34f824811f42c34c0d0cab83 from xrandr-AU Optronics
Oct 31 19:31:59 workhorse colord[410]: Profile removed: icc-5ca0354f34f824811f42c34c0d0cab83
Oct 31 19:31:59 workhorse colord[410]: Profile removed: icc-ef6504e2b2174a335d4ffde8a69bc6b7
Oct 31 19:31:59 workhorse colord[410]: Profile removed: icc-66804c56f215ade0f7739e903fd05d19
Oct 31 19:31:59 workhorse colord[410]: device removed: xrandr-AU Optronics
Oct 31 19:31:59 workhorse gdm-password][11625]: pam_unix(gdm-password:session): session closed for user bts
Oct 31 19:31:59 workhorse pulseaudio[613]: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true
Oct 31 19:31:59 workhorse rtkit-daemon[748]: Successfully made thread 616 of process 616 (/usr/bin/pulseaudio) owned by '1000' high priority at nice level -11.
Oct 31 19:31:59 workhorse rtkit-daemon[748]: Supervising 1 threads of 1 processes of 1 users.
Oct 31 19:31:59 workhorse pulseaudio[616]: [pulseaudio] pid.c: Stale PID file, overwriting.
Oct 31 19:31:59 workhorse sudo[12422]: pam_unix(sudo:session): session closed for user root
Oct 31 19:32:00 workhorse rtkit-daemon[748]: Supervising 1 threads of 1 processes of 1 users.
Oct 31 19:31:59 workhorse systemd-logind[389]: Removed session c4.
Oct 31 19:32:00 workhorse gnome-control-center.desktop[19498]: (gnome-control-center:19498): Gdk-WARNING **: gnome-control-center: Fatal IO error 11 (Resource temporarily unavailable) on X server :2.
Oct 31 19:32:00 workhorse rtkit-daemon[748]: Successfully made thread 617 of process 616 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
Oct 31 19:32:00 workhorse rtkit-daemon[748]: Supervising 2 threads of 1 processes of 1 users.
Oct 31 19:32:00 workhorse rtkit-daemon[748]: Supervising 2 threads of 1 processes of 1 users.
Oct 31 19:32:00 workhorse rtkit-daemon[748]: Successfully made thread 618 of process 616 (/usr/bin/pulseaudio) owned by '1000' RT at priority 5.
Oct 31 19:32:00 workhorse rtkit-daemon[748]: Supervising 3 threads of 1 processes of 1 users.
Oct 31 19:32:00 workhorse pulseaudio[616]: [pulseaudio] module-jackdbus-detect.c: Unable to contact D-Bus session bus: org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-kOmbuiSkVu: Connection refused
Oct 31 19:32:00 workhorse pulseaudio[616]: [pulseaudio] module.c: Failed to load module "module-jackdbus-detect" (argument: "channels=2"): initialization failed.

but i have NO idea if they're relevant or not.

Steps to reproduce:

-the only reliable reproduction i can do is [0]- and the page loads fine in google-chrome-unstable with no restart of gnome, so...
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Wednesday, 15 July 2015, 16:22 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#45009 
Comment by brent saner (sanerb) - Saturday, 01 November 2014, 00:01 GMT
note on cause [3] above, it occurs even if running via ssh on another system and just displaying locally (as that's how it's usually run when the issue occurs) so it leads me to believe that it's something tied to the local display component.
Comment by Doug Newgard (Scimmia) - Saturday, 01 November 2014, 14:16 GMT
Since we don't know where the problem lies, let's start high up in the stack.
Comment by Jan Alexander Steffens (heftig) - Saturday, 01 November 2014, 15:31 GMT
Looks like X crashes. Check journalctl -b0 SYSLOG_IDENTIFIER=gdm-Xorg-:0
Comment by brent saner (sanerb) - Saturday, 01 November 2014, 19:40 GMT
attached. was running from a clean boot, so generated via symptom [0] above.
Comment by Jakob Oesterling (Jakob_O) - Tuesday, 04 November 2014, 12:11 GMT
Exactly the same problem. Also the journalctl output seems similar (see attachmend). If you need further information or have tips what I can try please let me know.
I also tried to use KDE, Xfce and the same error occurs.
The activities when the error happens are:
- When I try to login in posteo.de email, (funny thing is google-chrome has no problems with this)
- When I start Intellij IDE and try to open a project
- When I start Protege
- Generally it seems to often occur in Java programms

Greetings Jakob
Comment by Jakob Oesterling (Jakob_O) - Tuesday, 04 November 2014, 20:02 GMT
So after some searching if found https://bbs.archlinux.org/viewtopic.php?pid=1470136.
And also the fix to make a /etc/X11/xorg.conf.d/20-intel.conf file and paste

Section "Device"
Identifier "Intel Graphic"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection

into it seems to work.
Comment by Andreas Radke (AndyRTR) - Saturday, 20 June 2015, 12:12 GMT
We had several Xorg and intel driver releases. Has this been solved?
Comment by Laurent Carlier (lordheavy) - Wednesday, 15 July 2015, 16:22 GMT
Probably duplicated of  FS#45009 , closing

Loading...