Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42505 - [linux] 3.17.1-1 fails to boot

Attached to Project: Arch Linux
Opened by Leopold Bloom (leopoldbloom) - Thursday, 23 October 2014, 07:32 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 02 March 2015, 16:57 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: linux 3.17.1-1 fails to boot


Additional info:
linux version 3.17.1-1 fails to boot; it immediately stops after reaching the stage "Creating Virtual Consoles..." and does not even load the display driver module. I do not have log information because I was forced to manually power down my system and, subsequently, my logs for the entire week have been corrupted and cannot be recovered.
This issue is not dependent on the intel ucode situation.

My system specs are:
Intel Core i7-3635QM
8GB DDR3 RAM
Intel HD Graphics 4000
Mobility Radeon 8770

Steps to reproduce:
1. Install linux 3.17.1-1
2. reboot

This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 02 March 2015, 16:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.17.4
Comment by Leopold Bloom (leopoldbloom) - Thursday, 23 October 2014, 18:03 GMT
I tried booting it again with the kernel module rtc-efi explicitly blacklisted and it still locks up at the same place in the boot process. Doesn't seem to have anything to do with https://bugs.archlinux.org/task/42509
Comment by Leopold Bloom (leopoldbloom) - Thursday, 23 October 2014, 18:59 GMT
Alright, after manually going through the log, I pinpointed the error and the resulting call trace. Hope this helps.
Comment by Clemens Koller (ckoller) - Thursday, 23 October 2014, 23:28 GMT
I am on an Intel i7 Samsung NP770Z5E notebook (an EFI system) and experience
also a complete lock in the middle of the boot process with 3.17.1-1.

The last lines showing are:
...
[OK] Started Load Kernel Modules
[OK] Started Create Static Devices Nodes in /dev.
Starting udev Kernel Device Manager...
[OK] Reached target Local File Systems (Pre).
Starting Apply Kernel Variables...
Mounting Configuration File System...
[OK] Started udev Kernel Device Manager.
[OK] Mounted Configuration File System.
[OK] Started Apply Kernel Variables.
-------- silence ---------

There is no difference if I load the intel-ucode.img during bootup or not.

So, this sems to be unrelated to the 3.17 changes as announced in:
[arch-announce] Changes to Intel microcode updates from
https://wiki.archlinux.org/index.php/Microcode#Enabling_Intel_Microcode_Updates

After downgrading to 3.16.4, the problem disappears.
Comment by Jian-Long Liu (lvlrdka22) - Friday, 24 October 2014, 06:22 GMT
I have exactly the same problem. It doesn't seem like it's the microcode updates, since I have
Oct 23 23:00:17 test-tablet kernel: CPU0 microcode updated early to revision 0x1b, date = 2014-05-29
Oct 23 23:00:17 test-tablet kernel: CPU1 microcode updated early to revision 0x1b, date = 2014-05-29
Oct 23 23:00:17 test-tablet kernel: microcode: CPU0 sig=0x306a9, pf=0x10, revision=0x1b
Oct 23 23:00:17 test-tablet kernel: microcode: CPU1 sig=0x306a9, pf=0x10, revision=0x1b
Oct 23 23:00:17 test-tablet kernel: microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba

Samsung XE700T1C-A02US:
Intel Core i5 3317u
4GB DDR3 RAM
Intel HD Graphics 4000
Comment by Thomas Toulorge (eltoul) - Saturday, 25 October 2014, 01:27 GMT
I have the same problem on a Samsung NP740U3E notebook (Intel Core i5, 4GB RAM,
Intel HD Graphics 4000). Intel-ucode is not installed.

After enabling the kernel debugging output, I found out that the system freezes
when switching graphics mode. Disabling Kernel Mode Setting by passing the
"nomodeset i915.modeset=0" parameters to the kernel allows the boot to complete.
If the VESA driver is installed, X even works, though tremendously slow. The only
proper workaround I found is to downgrade to linux 3.16.4-1.

Bug #86551 upstream seems to be the same:
https://bugzilla.kernel.org/show_bug.cgi?id=86551

Hope this helps.
Comment by Leopold Bloom (leopoldbloom) - Saturday, 25 October 2014, 03:11 GMT
After adding the i915 kernel module to the udev early hooks and regenerating the initramfs image on kernel 3.17.1-1, the boot process locks up immediately after the early hooks are loaded, which confirms the above comment. The bug exists in either in the i915 module or how it is loaded/handled.
Comment by Gergan Penkov (gergan) - Saturday, 25 October 2014, 16:57 GMT
I could confirm that using the patch, which was proposed in the comment https://bugzilla.kernel.org/show_bug.cgi?id=86551#c6 to bug #86551 fixes the issue for me.
Comment by Jian-Long Liu (lvlrdka22) - Sunday, 26 October 2014, 06:41 GMT
I tried the patch. Both booted up fine, but as soon as I run startx, all inputs stop responding. I've tried keyboard, mouse, pen, touchscreen, and USB keyboard/mouse.
I can see that it's not frozen though, since the stats (CPU/memory/net usage, etc.) I have setup for awesome still get updated. This happens on both 3.17.1 and 3.18-rc1.
Comment by Willian Pedro (willianpts) - Friday, 31 October 2014, 00:10 GMT
Same problem here. With "nomodeset" option i can get into text mode.
Confirmed on kernel 3.17.x and 3.18-rc2

Samsung NP200B4C laptop
Intel Core i3 3110m
VGA Intel HD4000
Comment by patrick (potomac) - Sunday, 02 November 2014, 20:19 GMT
I think there are 2 bugs in one here,

because I notice some random hangs with kernel 3.17.1 and 3.17.2 at boot

every 5~10 boots a freeze can occur shortly after the load of the kernel, I can see these message and then nothing, it seems a freeze :

:: running early hook [udev]
:: running hook [udev]
:: Triggering uvents...

sometimes the freeze happens a few seconds after systemd starts ( after the message "mount /home" for example,

I suspect the new loading mode of "intel-ucode" package, it can bring some collision/timing problems

my configuration :
archlinux 64 bits
cpu pentium dual core E6800 3.33 Ghz
ati radeon HD4650 PCIe ( radeon open source driver, KMS early start )



Comment by patrick (potomac) - Sunday, 02 November 2014, 22:28 GMT
finaly the culprit is not intel-ucode,

because when the freeze occurs after the start of systemd I can have this kernel trace message ( 120 seconds after the freeze ), I took a photo of my screen :

https://bugzilla.kernel.org/attachment.cgi?id=156341
Comment by patrick (potomac) - Monday, 03 November 2014, 00:41 GMT
I solved my problem by installing the testing version of systemd ( 217-3 ) :

https://www.archlinux.org/packages/testing/x86_64/systemd/

it seems that the current version of systemd ( 216-3 ) has a problem with kernel 3.17.x
Comment by patrick (potomac) - Monday, 03 November 2014, 00:57 GMT
well I was too optimistic, because after further tests I have again the bug
Comment by Willian Pedro (willianpts) - Thursday, 06 November 2014, 21:21 GMT
In my case, The latest patch on the bugzilla thread solved the issue on 3.17.2

https://bugzilla.kernel.org/attachment.cgi?id=156641&action=diff
Comment by Leopold Bloom (leopoldbloom) - Saturday, 15 November 2014, 12:10 GMT
alright, linux 3.17.3 is out but the patch above didn't land, and the kernel is still broken. Could the Arch Kernel people include the patch?
Comment by Leopold Bloom (leopoldbloom) - Saturday, 22 November 2014, 11:40 GMT
kernel 3.17.4 fixes this bug. could someone close this?

Loading...