FS#42455 - [evolution] crashes with current version of sqlite

Attached to Project: Arch Linux
Opened by Ralf Mardorf (Ralf) - Monday, 20 October 2014, 10:43 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 18 November 2014, 09:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



Evolution doesn't start and segfaults when current version of sqlite is installed. Downgrading to the previous version solved this issue.

Additional info:

It's ok for
[rocketmouse@archlinux ~]$ pacman -Q sqlite evolution
sqlite 3.8.6-1
evolution 3.12.7-1

but current version is
[rocketmouse@archlinux ~]$ pacman -Si sqlite
Repository : extra
Name : sqlite
Version : 3.8.7-1


Steps to reproduce:

Simply trying to launch Evo does cause the segfault.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 18 November 2014, 09:33 GMT
Reason for closing:  Fixed
Comment by Roland Lezuo (iroli) - Monday, 27 October 2014, 20:40 GMT
same here, although it depends on the evoltuion database, i.e. I have observed the crash for one user while evoltion was fine for a different user.
Downgrading sqlite solved the problem though.
Comment by Jan de Groot (JGC) - Tuesday, 28 October 2014, 07:58 GMT
This is fixed upstream already, so we need to package a git snapshot of evolution-data-server to fix this.