Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#42444 - merge the funcionality of testdb into main pacman program

Attached to Project: Pacman
Opened by Cyker Way (cyker) - Sunday, 19 October 2014, 02:33 GMT
Last edited by Allan McRae (Allan) - Monday, 12 January 2015, 05:38 GMT
Task Type Feature Request
Category Scripts & Tools
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.1.2
Due in Version 5.0.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

It's good to ensure the pacman database in a good state, especially after a user installs packages without dependency check. Currently `testdb` does this task, but it doesn't have a man page. Since `testdb` is not a large problem, it should be possible to merge its functionality into main pacman program and define dependency check as an operation there. Currently pacman has `-T` option, but they don't seem to work in the same way.
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 12 January 2015, 05:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  commit e8a3e3d81a4a
Comment by Allan McRae (Allan) - Wednesday, 19 November 2014, 06:55 GMT
We have -D for database operations. So "pacman -D --check" would make sense.
Comment by Cyker Way (cyker) - Monday, 24 November 2014, 06:24 GMT
Here's what "pacman -D --check" gives me:

error: invalid option

I think "--check" is listed in man page as a query operation.
Comment by Allan McRae (Allan) - Monday, 24 November 2014, 07:47 GMT
I was saying that is the flags that should do testdb - not that it does...
Comment by Cyker Way (cyker) - Monday, 24 November 2014, 15:43 GMT
That's cool. Thanks~

Loading...