Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#42442 - [evolution] version 3.12.7-1 breaks GUI under KDE4: tick boxes in menus

Attached to Project: Arch Linux
Opened by Stefan Förster (HotblackDesiato) - Saturday, 18 October 2014, 22:32 GMT
Last edited by Jan de Groot (JGC) - Friday, 31 October 2014, 10:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



I use evolution under KDE4 on three of my Linux machines with the Oxygen GTK design (since it is one of the rare designs with fully implemented GTK2 and GT3 versions). Up to now, evolution worked with the GTK3 design. Since update of evolution from 3.12.5-1 to 3.12.7-1, tick boxes in menus are no longer rendered. I no longer see whether an option is ticked or not.

I don't believe that this bug is dependent on the theme. I have tried Adwaita, the Gnome standard theme, but the tick boxes are not shown either. But, it seems to be GUI dependent. On my notebook under XFCE4 and Adwaita evolution works as expected.

I downgraded to 3.12.5-1, but the bug still persists! Before the update, 3.12.5-1 worked as expected. Thus this bug is evolution dependent, has nothing to do with Gnome.

Steps to reproduce:
1) Upgrade evolution from 3.12.5-1 to 3.12.7-1.
2) Start KDE. Optionally choose Oxygen as GTK3 theme.
3) Start evolution
4) Write an email. Open the menu, for instance "options". Try to check/uncheck any of the options (e.g. encryption with PGP). No tick boxes are shown.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 31 October 2014, 10:51 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Sunday, 19 October 2014, 16:59 GMT
Probably oxygen theme is not compatible with latest gtk yet.
Comment by Stefan Förster (HotblackDesiato) - Sunday, 19 October 2014, 21:23 GMT
Adwaita doesn't work either. There hasn't been an update of GTK in October, isn't it? Oxygen worked until the Evolution update on Oct 16. I doubt that this is related to the Oxygen theme.
Comment by Stefan Förster (HotblackDesiato) - Wednesday, 22 October 2014, 16:07 GMT
  • Field changed: Percent Complete (100% → 0%)
I just performed a full upgrade of one of the affected machines. Unfortunately the bug persists. I still believe it is not the oxygen package causing this bug.
Comment by Stefan Förster (HotblackDesiato) - Sunday, 26 October 2014, 08:15 GMT
The bug can now be closed. Since my last posting there have been updates of both oxygen and gtk. I have updated both packages today and the missing tick boxes are back on both machines.