Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42425 - [lxsession] no session for pid xxxxx when vncserver service is started

Attached to Project: Community Packages
Opened by John (graysky) - Friday, 17 October 2014, 21:01 GMT
Last edited by Balló György (City-busz) - Friday, 07 November 2014, 11:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Since updating to 1:0.5.0-1, starting an lxde-session via systemd service calling vnc (tigervnc) causes an error upon startup that reads, "Error: No session for pid xxxxx." When I `ps aux | grep xxxxx` the offending pid belongs to lxpolkit. For example:

% ps aux | grep 30426
facade 30426 0.1 0.4 252236 18012 ? Sl 16:40 0:00 lxpolkit

There is nothing relevant in ~/.vnc/hostname:1.log but this is reproducible on several machines.

Additional info:
* package version(s) 1:0.5.0-1

Steps to reproduce:
1) install tigervnc and lxde
2) create ~/.vnc/xstartup that contains a single line that reads: exec startlxde
3) cp /usr/lib/systemd/system/vncserver.service /etc/systemd/system/vncserver@:1.service
4) configure this file setting up the user to run vncsession
5) configure a passwd for vnc (first time run only) via `vncserver :1` and then kill the server `vncserver -kill :1`
6) start the systemd service to observe the error
This task depends upon

Closed by  Balló György (City-busz)
Friday, 07 November 2014, 11:04 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#42703 
Comment by Nathan Acks (necopinus) - Wednesday, 05 November 2014, 21:46 GMT
I've run in to this same problem. For me, the solution was to add PAMName=login to the [Service], set Type=simple, and add the -fg directive to the vncserver command. See the attached file for details.

BOTH changes were necessary for me -- both the PAMName directive and changing the service to be non-forking. Neither by itself was effective.

YMMV.
Comment by John (graysky) - Friday, 07 November 2014, 10:31 GMT
Works for me as well. Wiki updated and opened  FS#42703 . Thank you, necopinus.

Loading...