Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42415 - [nautilus] launcher breaks upon upgrade to GNOME 3.14

Attached to Project: Arch Linux
Opened by Leopold Bloom (leopoldbloom) - Friday, 17 October 2014, 04:54 GMT
Last edited by Jan de Groot (JGC) - Monday, 01 December 2014, 18:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: Nautilus launcher breaks upon upgrade to GNOME 3.14.

Additional info:

The launcher is renamed org.gnome.Nautilus.desktop upon upgrade and refuses to launch, but renaming it back to Nautilus.desktop fixes the problem.

Steps to reproduce:
1. Upgrade to GNOME 3.14
2. Try opening Nautilus from the applications menu
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 01 December 2014, 18:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with nautilus 3.14.2.
Comment by Jan Alexander Steffens (heftig) - Friday, 17 October 2014, 15:24 GMT
Which menu is this? I cannot reproduce using the Application Menu shell extension.
Comment by Frank Theile (frank-ka) - Thursday, 13 November 2014, 17:42 GMT
I can confirm this bug, but I can not say when I first discovered it.

[1] Move your mouse in the top left corner, search for "Nautilus", click the Nautilus icon -> nothing happens.

For a short test, I copied /usr/share/applications/org.gnome.Nautilus.desktop to ~/.local/share/applications/Nautilus.desktop.
If I now repeat procedure [1] above, I see two Nautilus icons. One not working as before, the other one starts Nautilus.
Comment by Marcos (patparad) - Sunday, 30 November 2014, 14:13 GMT
I have the same problem and I can also confirm that changing the launcher name solves it.
In the meanwhile I found two other workarounds:
1. the problem can also be solved by killing nautilus and starting it again, or by
2. preventing nautilus to handle desktop icons.

Loading...