Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42323 - python2-matplotlib crashes without libxkbcommon-x11 installed

Attached to Project: Community Packages
Opened by Li Jiapeng (jpli) - Friday, 10 October 2014, 09:09 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 10 October 2014, 14:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

## Description

Starting from 5.3.0-1, qt5-base needs optional dependency libxkbcommon-x11 for xcb plugin.
https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/qt5&id=55360dcae3bd1ce6689d0b11dc18b12cfe1f57fd

python2 will crash, if the user tries to create a figure using the default backend "qt5agg", see the error message in the Steps-to-produce section.

The message shows xcb plugin is installed but fails to function properly, this post explains the cause of the problem:
http://forum.teamspeak.com/showthread.php/97133-Qt-platform-plugin-quot-xcb-quot?s=ccf6a698779ad2fbbda63e4a1db7e69a&p=379193#post379193

Run ldd on /usr/lib/qt/plugins/platforms/libqxcb.so shows the following error message
libxkbcommon-x11.so.0 => not found

Install libxkbcommon-x11 package solves the problem

So I guess if python2-matplotlib continues to use "qt5agg" as the default backend, it should include libxkbcommon-x11 in the dependency list, like qt5-declarative or smplayer does.
https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/qt5&id=3d4ebe3f590c4e08cdbce815a9b9ccd17c008c31
https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/smplayer&id=5e73a0b3e6e3ab6706bf9dc70a250be8f38cbc33

Or a different backend can be used
https://bugs.archlinux.org/task/41820?project=5&cat[0]=33&string=python2-matplotlib

## Additional info

$ pacman -Qi python2-matplotlib
Name : python2-matplotlib
Version : 1.4.0-2
...

$ pacman -Qi qt5-base
Name : qt5-base
Version : 5.3.2-1
...

## Steps to reproduce

Without package `libxkbcommon-x11` installed

$ python2 -c "import pylab; pylab.figure()"
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 10 October 2014, 14:04 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#42307 

Loading...