Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42272 - [nvidia-340xx] [nvidia] needs to be rebuilt for kernel in testing

Attached to Project: Arch Linux
Opened by Eric Belanger (Snowman) - Monday, 06 October 2014, 19:07 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 07 October 2014, 14:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Sven-Hendrik Haase (Svenstaro)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:

$ sudo pacman -Syu
:: Synchronizing package databases...
testing 164.3 KiB 30.7K/s 00:05 [-----------------------------------------------] 100%
core 116.7 KiB 32.6K/s 00:04 [-----------------------------------------------] 100%
extra 1778.5 KiB 23.8K/s 01:15 [-----------------------------------------------] 100%
community-testing 57.6 KiB 50.9K/s 00:01 [-----------------------------------------------] 100%
community 2.3 MiB 23.3K/s 01:42 [-----------------------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-340xx: requires linux<3.17
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 07 October 2014, 14:02 GMT
Reason for closing:  Fixed
Comment by John (graysky) - Monday, 06 October 2014, 20:00 GMT
Actually, 340.46-2 in [extra] requires a rebuild against linux-3.16.4-1:

nvidia: disagrees about version of symbol module_layout
Comment by Doug Newgard (Scimmia) - Monday, 06 October 2014, 23:23 GMT
And nvidia in testing doesn't work either, as the install file seems to be wrong on all of the nvidia packages.
Comment by Eric Belanger (Snowman) - Tuesday, 07 October 2014, 13:37 GMT
nvidia-340xx isn't fixed yet
Comment by Eric Belanger (Snowman) - Tuesday, 07 October 2014, 13:39 GMT
I'm talking about 340xx not 304xx in case you're misreading it.

Loading...