Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42267 - [pychess] crashed when started

Attached to Project: Community Packages
Opened by Munzir Taha (munzirtaha) - Monday, 06 October 2014, 16:12 GMT
Last edited by Alexander F. Rødseth (xyproto) - Tuesday, 04 November 2014, 15:20 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
% pychess
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: The property GtkDialog:has-separator is deprecated and shouldn't be used anymore. It will be removed in a future version.
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
19:03:41 Default Warning: no weather-clear icon in icon-theme-gnome
19:03:41 Default Warning: no weather-clear-night icon in icon-theme-gnome
19:03:41 Default Warning: no gtk-close icon in icon-theme-gnome
19:03:41 Default Warning: no gtk-media-previous-ltr icon in icon-theme-gnome
19:03:41 Default Warning: no gtk-media-rewind-ltr icon in icon-theme-gnome
19:03:41 Default Warning: no gtk-media-forward-ltr icon in icon-theme-gnome
19:03:41 Default Warning: no gtk-media-next-ltr icon in icon-theme-gnome
19:03:41 Default Warning: no appointment-soon icon in icon-theme-gnome
19:03:41 Default Warning: no system-users icon in icon-theme-gnome
19:03:41 Default Warning: no gtk-execute icon in icon-theme-gnome
19:03:41 Default Warning: no system-users icon in icon-theme-gnome
19:03:41 Default Warning: no computer icon in icon-theme-gnome
19:03:41 Default Warning: no system-users icon in icon-theme-gnome
19:03:41 Default Warning: no computer icon in icon-theme-gnome
19:03:41 Default Warning: no weather-clear icon in icon-theme-gnome
19:03:41 Default Warning: no weather-few-clouds icon in icon-theme-gnome
19:03:41 Default Warning: no weather-few-clouds icon in icon-theme-gnome
19:03:41 Default Warning: no weather-overcast icon in icon-theme-gnome
19:03:41 Default Warning: no weather-overcast icon in icon-theme-gnome
19:03:41 Default Warning: no weather-showers icon in icon-theme-gnome
19:03:41 Default Warning: no weather-showers icon in icon-theme-gnome
19:03:41 Default Warning: no weather-storm icon in icon-theme-gnome
19:03:41 Default Warning: no weather-clear icon in icon-theme-gnome
19:03:41 Default Warning: no weather-few-clouds icon in icon-theme-gnome
19:03:41 Default Warning: no weather-few-clouds icon in icon-theme-gnome
19:03:41 Default Warning: no weather-overcast icon in icon-theme-gnome
19:03:41 Default Warning: no weather-overcast icon in icon-theme-gnome
19:03:41 Default Warning: no weather-showers icon in icon-theme-gnome
19:03:41 Default Warning: no weather-showers icon in icon-theme-gnome
19:03:41 Default Warning: no weather-storm icon in icon-theme-gnome
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_object_newv: object class 'GtkWindow' has no property named 'has_separator'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
19:03:41 Default Warning: no applications-internet icon in icon-theme-gnome
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_value_transform: assertion 'G_IS_VALUE (src_value)' failed
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: unable to set property 'has-separator' of type 'gboolean' from value of type '(null)'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/Main.py:240: GtkWarning: IA__gtk_widget_set_events: assertion '!gtk_widget_get_realized (widget)' failed
widgets["menubar1"].set_events(widgets["menubar1"].get_events() | gtk.gdk.DRAG_STATUS)
/usr/lib/python2.7/site-packages/pychess/Main.py:241: GtkWarning: IA__gtk_widget_set_events: assertion '!gtk_widget_get_realized (widget)' failed
widgets["Background"].set_events(widgets["Background"].get_events() | gtk.gdk.DRAG_STATUS)
Attempt to unlock mutex that was not locked
[1] 3834 abort (core dumped) pychess


Additional info:
* package version(s): 0.10.1-4
* gnome 3.14.0-1
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Tuesday, 04 November 2014, 15:20 GMT
Reason for closing:  Works for me
Additional comments about closing:  Works for me / not a bug? Seems to work for everyone involved.
Comment by Alexander F. Rødseth (xyproto) - Thursday, 16 October 2014, 13:15 GMT
I'm unable to reproduce this problem. pychess installs and starts fine here. Are you using any unofficial packages from AUR that might be related to this?
Comment by Karol Błażewicz (karol) - Thursday, 16 October 2014, 18:08 GMT
I could reproduce this problem when this bug report was posted but some update took care of it and it runs fine now.
Comment by Munzir Taha (munzirtaha) - Thursday, 16 October 2014, 19:33 GMT
I confirm the bug is fixed now
Comment by Karol Błażewicz (karol) - Saturday, 25 October 2014, 18:25 GMT
  • Field changed: Percent Complete (100% → 0%)
I've got the bug again.
Comment by Karol Błażewicz (karol) - Saturday, 25 October 2014, 19:20 GMT
Now it works again, but I get

$ pychess
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: The property GtkDialog:has-separator is deprecated and shouldn't be used anymore. It will be removed in a future version.
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_object_newv: object class 'GtkWindow' has no property named 'has_separator'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:465: Warning: g_object_newv: object class 'GtkWindow' has no property named 'has_separator'
self.glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_param_spec_pool_lookup: assertion 'param_name != NULL' failed
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_object_newv: object class 'GtkWindow' has no property named '(null)'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_value_transform: assertion 'G_IS_VALUE (src_value)' failed
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: unable to set property 'border-width' of type 'guint' from value of type '(null)'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: unable to set property 'title' of type 'gchararray' from value of type '(null)'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: unable to set property 'resizable' of type 'gboolean' from value of type '(null)'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: unable to set property 'icon-name' of type 'gchararray' from value of type '(null)'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: unable to set property 'type-hint' of type 'GdkWindowTypeHint' from value of type '(null)'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: unable to set property 'has-separator' of type 'gboolean' from value of type 'gchararray'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/Main.py:240: GtkWarning: IA__gtk_widget_set_events: assertion '!gtk_widget_get_realized (widget)' failed
widgets["menubar1"].set_events(widgets["menubar1"].get_events() | gtk.gdk.DRAG_STATUS)
/usr/lib/python2.7/site-packages/pychess/Main.py:241: GtkWarning: IA__gtk_widget_set_events: assertion '!gtk_widget_get_realized (widget)' failed
widgets["Background"].set_events(widgets["Background"].get_events() | gtk.gdk.DRAG_STATUS)

on the first run. I closed it (quit) and tried to run again but it just crashes:

$ pychess
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: The property GtkDialog:has-separator is deprecated and shouldn't be used anymore. It will be removed in a future version.
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_object_newv: object class 'GtkWindow' has no property named 'has_separator'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_object_newv: object class 'GtkWindow' has no property named 'license'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_object_newv: object class 'GtkWindow' has no property named 'authors'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
/usr/lib/python2.7/site-packages/pychess/System/uistuff.py:447: Warning: g_object_newv: object class 'GtkWindow' has no property named 'documenters'
glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
Segmentation fault (core dumped)

What am I doing wrong?
Comment by Alexander F. Rødseth (xyproto) - Monday, 27 October 2014, 10:56 GMT
Thanks for testing, will try to reproduce the problem again.
Comment by Alexander F. Rødseth (xyproto) - Monday, 27 October 2014, 13:21 GMT
I get several warnings, but pychess starts fine every time here. Unable to reproduce the problem.
Comment by Karol Błażewicz (karol) - Monday, 27 October 2014, 15:13 GMT
You're right. I've set up Arch on another computer and it works there :-(
Comment by Karol Błażewicz (karol) - Sunday, 02 November 2014, 07:22 GMT
pychess-hg from the AUR works.
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 04 November 2014, 15:18 GMT
Ok. Please re-open if there should be further issues with this. Closing this one.

Loading...