Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#4216 - xf86-video-i810: lacks recent libshadow

Attached to Project: Arch Linux
Opened by Alexander Baldeck (kth5) - Monday, 20 March 2006, 22:17 GMT
Last edited by Alexander Baldeck (kth5) - Monday, 20 March 2006, 22:18 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture not specified
Severity Medium
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

according to the Changelog file, the driver (testing/xf86-video-i810-1.5.1.0-1) should support rotation with DRI and XAA. for this it depends on a newer version of libshadow (1.1.0) which - i was thinking - comes with xorg-server. the problem is that even in the cvs checkout i cannot seem to find the proper files to update my libshadow from current's xorg-server (libshadow 1.0.0) to make it work.

without libshadow, neither rotation nor acceleration in rotated mode works. modifying the version number in hw/xfree86/dixmods/sfb*.h (have the checkout at work, sry) didn't help, instead a random filled square at the center of the screen appears. so obviously, libshadow is not yet updated to what xf86-video-i810 was developed against?!

any help apreciated.
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 11 June 2006, 18:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  xf86-video-i810 gets removed from testing, please downgrade to the one in current.
this version was targeted at Xorg 7.1
Comment by Alexander Baldeck (kth5) - Tuesday, 21 March 2006, 09:51 GMT Comment by Krzysztof Rosiński (kr) - Wednesday, 22 March 2006, 05:45 GMT
You could use the latest drivers from http://www.fairlite.demon.co.uk/intel.html to make it work.
Comment by Alexander Baldeck (kth5) - Saturday, 25 March 2006, 00:22 GMT
didn't work either. it gave me a b/w screen which seemed to run at a lower resolution as the actual screen. rotation did not work either.
but thanks. :)
Comment by Krzysztof Rosiński (kr) - Saturday, 25 March 2006, 03:40 GMT
What did the xorg log say when you used this libshadow.so 1.1.0 module?

Loading...