Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42168 - [sdl] Flickering in 1.2.15-7 (Regression from 1.2.15-6)

Attached to Project: Arch Linux
Opened by Daniel (weirddan455) - Monday, 29 September 2014, 06:29 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 03 October 2019, 14:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Since the update to SDL 1.2.15-7 I noticed a constant flickering in mupen64plus in full screen (windowed is fine.) It's only noticible on parts of the screen that are moving and it looks like it's flickering back and forth between the current frame and the previous frame. It's very noticible and gives me a headache immediately. I can reproduce this reliably and can confirm downgrading back to SDL 1.2.15-6 resolves this issue.

Steps to reproduce:
1. Load a ROM in Mupen64plus (I used Zelda Ocarina of Time)

2. Go Full Screen

3. The title screen will look fine but start a game and move Link around and you should notice the flickering immediatly around Link's model.

Other games/programs using SDL may or may not have this same issue. I haven't tested.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 03 October 2019, 14:51 GMT
Reason for closing:  Fixed
Comment by Jan Alexander Steffens (heftig) - Thursday, 02 October 2014, 13:07 GMT
Cannot reproduce using mupen64plus or other SDL apps.
Comment by Daniel (weirddan455) - Saturday, 04 October 2014, 04:56 GMT
It's probably specific to the proprietary Nvidia driver. I tested on Nouveau and the bug didn't appear there. Anyway I found the offending patch "SDL-1.2.15-no-default-backing-store.patch" Recompiling from ABS without that patch fixes this bug. I read the upstream bug report but it was pretty vauge on what the benifits of this patch would be and the comment /* This is an experiment - are the graphics faster now? - nope. */ doesn't inspire much confidince either. Is there a good reason for this patch to be included? If not I suggest removing it because I doubt I'm the only Nvidia user affected by this.
Comment by Jan Alexander Steffens (heftig) - Saturday, 04 October 2014, 08:16 GMT Comment by Jan Alexander Steffens (heftig) - Saturday, 04 October 2014, 08:21 GMT
So with SDL from extra and SDL_VIDEO_X11_BACKINGSTORE=1 you don't have any problems, either?
Comment by Daniel (weirddan455) - Saturday, 04 October 2014, 08:28 GMT
Oh I didn't realize it was just an environment variable but yes setting that also resolves this issue.

Loading...