Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42121 - [xf86-video-nouveau] X crashes when calling xrandr with xf86-video-nouveau-1.0.11-1

Attached to Project: Arch Linux
Opened by cdep.illabout (cdep.illabout) - Thursday, 25 September 2014, 21:09 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 25 October 2014, 07:20 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Upgrading from xf86-video-nouveau-1.0.10-3 to xf86-video-nouveau-1.0.11-1 causes X to crash when calling xrandr. I use xrandr to setup two monitors, so it makes the newest version of xf86-video-nouveau unusable for me.

This is an example of what causes xrandr to crash:

$ xrandr --output LVDS-1 --auto --primary --rotate left


I have attached the Xorg.0.log files from running X with xf86-video-nouveau-1.0.10-3 and xf86-video-nouveau-1.0.11-1. Everything pretty much looks the same. No big differences.

I have also attached the output of `startx`. Despite xf86-video-nouveau-1.0.10-3 being the one that works with xrandr, it looks like it spits out a stack trace when exiting from X and going back to the console. (This, of course, causes no problems to me as a user because I've already exited X.)

If you look in the file startx-output-xf86-video-nouveau-1.0.11-1, you can see the following suspicious lines:

resize called 1920 1920
/usr/bin/Xorg.bin: symbol lookup error: /usr/lib/xorg/modules/drivers/nouveau_drv.so: undefined symbol: exaGetPixmapDriverPrivate

I bet the "resize called" line is produced when calling `xrandr`, and then the following line is what actually causes X to crash.

After googling around for the cause, I only really found the following page:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1210316


Here is the output of `lscpi -v` for my card:

01:00.0 VGA compatible controller: NVIDIA Corporation GF116M [GeForce GT 560M] (rev a1) (prog-if 00 [VGA controller])
Subsystem: CLEVO/KAPOK Computer Device 5102
Flags: bus master, fast devsel, latency 0, IRQ 54
Memory at f4000000 (32-bit, non-prefetchable) [size=32M]
Memory at e8000000 (64-bit, prefetchable) [size=128M]
Memory at f0000000 (64-bit, prefetchable) [size=64M]
I/O ports at e000 [size=128]
Expansion ROM at f6000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Kernel driver in use: nouveau
Kernel modules: nouveau
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 25 October 2014, 07:20 GMT
Reason for closing:  No response
Comment by cdep.illabout (cdep.illabout) - Thursday, 25 September 2014, 21:16 GMT
On the Arch Linux News page for the xorg-server 1.6 update, it says that glamor accelerated rendering has been deprecated and the glamor package removed, but one of the comments on the ubuntu launchpad page mentions glamor, so I'm wondering if that is where the problem lies.

launchpad comment:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1210316/comments/5

xorg-server 1.6 update page:
https://www.archlinux.org/news/xorg-server-116-is-now-available/
Comment by Doug Newgard (Scimmia) - Friday, 26 September 2014, 02:22 GMT
You completely misread that news item. The glamor-egl package was deprecated because glamor is now built into the server.
Comment by cdep.illabout (cdep.illabout) - Friday, 26 September 2014, 10:50 GMT
You're right!

Is there anything I can do to try to figure out why xrandr is not working? I'm not too familiar with how to go about debugging problems with X.
Comment by Andreas Radke (AndyRTR) - Thursday, 09 October 2014, 19:11 GMT
Feel free to report this upstream if something went broken.

Loading...