Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42076 - [ca-certificates-utils] 20140923-2 fails to install

Attached to Project: Arch Linux
Opened by Gene (GeneC) - Tuesday, 23 September 2014, 02:04 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 23 September 2014, 06:32 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Pierre Schmitz (Pierre)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:ca-certificates-utils-20140923-2-any fails to install
when updating via pacman -Syu:

...
:: Starting full system upgrade...
:: Replace ca-certificates-java with testing/ca-certificates-utils? [Y/n]
...
Packages (8): ca-certificates-20140923-2 ca-certificates-cacert-20140824-2
ca-certificates-java-20140324-4 [removal] ca-certificates-mozilla-3.17-4
ca-certificates-utils-20140923-2 nss-3.17-4 p11-kit-0.20.7-2
...
(1/1) checking for file conflicts [####################################] 100%
error: failed to commit transaction (conflicting files)
ca-certificates-utils: /etc/ssl/certs/java/cacerts exists in filesystem
Errors occurred, no packages were upgraded.


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 23 September 2014, 06:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  Reverted.
Comment by Doug Newgard (Scimmia) - Tuesday, 23 September 2014, 02:51 GMT
And where is that file from? Use pacman -Qo.
Comment by Matthias Lisin (matthias.lisin) - Tuesday, 23 September 2014, 03:34 GMT
@ Doug Newgard
Package: ca-certificates-java

It's created by ca-certificates-java.install (post_install):
https://projects.archlinux.org/svntogit/packages.git/tree/trunk/ca-certificates-java.install?h=packages/ca-certificates-java
Comment by Doug Newgard (Scimmia) - Tuesday, 23 September 2014, 03:39 GMT
So usr/bin/init-jks-keystore creates it?

Looks like it should be removed in post_remove, though. Seems like a pacman bug, seeing a file as a conflict even though it won't exist when the new package is installed.
Comment by Allan McRae (Allan) - Tuesday, 23 September 2014, 03:46 GMT
Not a pacman bug. Pacman does the right thing given it does track the ownership of the file.
Comment by Doug Newgard (Scimmia) - Tuesday, 23 September 2014, 03:49 GMT
OK, not bug, but a limitation of Pacman.
Comment by Matthias Lisin (matthias.lisin) - Tuesday, 23 September 2014, 04:03 GMT
ca-certificates-java creates 'etc/ssl/certs/java/cacerts' in post_install
ca-certificates-utils already has this file in the package contents.

Pacman would need a hint about files created created/removed in post_/pre_ functions. That's more of a nice-to-have feature than a bug ;)
Comment by Jan Alexander Steffens (heftig) - Tuesday, 23 September 2014, 06:31 GMT
This got rushed, poorly, and the updates were removed. I'm very sorry.
Please downgrade again:

pacman -S core/ca-certificates{,-cacert,-utils} extra/{nss,ca-certificates-{mozilla,java},p11-kit}

And if you have multilib:

pacman -S multilib/lib32-p11-kit

Loading...