Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42060 - [netbeans] File conflicts during upgrade on netbeans 8.0.1-1

Attached to Project: Community Packages
Opened by Peter Weber (hoschi) - Monday, 22 September 2014, 07:15 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 22 September 2014, 14:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Hello! During the upgrade from netbeans-8.0-3 to netbeans 8.0.1-1 pacmans fails to commit the transaction:

Additional info:
* package version(s): 8.0-3 -> 8.0.1-1
* log:
# pacman -Syyu
...
netbeans-8.0.1-1-any 248.1 MiB 3.83M/s 01:05 [################################] 100%
virtualbox-host-modules-4.3.1... 166.9 KiB 4.53M/s 00:00 [################################] 100%
(38/38) checking keys in keyring [################################] 100%
(38/38) checking package integrity [################################] 100%
(38/38) loading package files [################################] 100%
(38/38) checking for file conflicts [################################] 100%
error: failed to commit transaction (conflicting files)
netbeans: /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/killall exists in filesystem
netbeans: /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/process_start exists in filesystem
netbeans: /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/pty exists in filesystem
netbeans: /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/pty_open exists in filesystem
netbeans: /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/sigqueue exists in filesystem
netbeans: /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/stat exists in filesystem
netbeans: /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/unbuffer.so exists in filesystem
Errors occurred, no packages were upgraded.

# pacman -Qo /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/killall
error: No package owns /usr/share/netbeans/ide/bin/nativeexecution/Linux-arm/killall


Steps to reproduce:
Upgrade the system with pacman.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 22 September 2014, 14:03 GMT
Reason for closing:  Not a bug
Comment by Peter Weber (hoschi) - Monday, 22 September 2014, 07:17 GMT
I'm not doing any development for ARM, maybe some kind of accidentally installed plugin?

$ stat Linux-arm/
File: ‘Linux-arm/’
Size: 4096 Blocks: 8 IO Block: 4096 directory
Device: 811h/2065d Inode: 1967398 Links: 2
Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2014-08-18 10:22:50.161792113 +0200
Modify: 2014-08-18 10:22:50.175125446 +0200
Change: 2014-08-18 10:22:50.175125446 +0200
Birth: -

No update of Netbeans during that day, but:
[2014-08-18 09:23] [PACMAN] installed java-common (1-3)

Fluke? I don't believe in.

Comment by Peter Weber (hoschi) - Monday, 22 September 2014, 08:48 GMT
Well. I've archived the directory and deleted it, to be able to execute the upgrade:

1. $ cd /usr/share/netbeans/ide/bin/nativeexecution
2. $ tar -cz Linux-arm -f ~/netbeans_Linux-arm.tar.gz
3. $ su
4. # rm -r Linux-arm
5. # pacman -Syu
Comment by Doug Newgard (Scimmia) - Monday, 22 September 2014, 14:03 GMT
If the files didn't belong to a package, it's not something that pacman did.

Loading...