Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#42030 - [qt4] unetbootin fails to load properly; an empty grey window appears.

Attached to Project: Community Packages
Opened by Georgios Tzanakis (geo909) - Friday, 19 September 2014, 22:29 GMT
Last edited by Balló György (City-busz) - Wednesday, 24 January 2018, 06:03 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description:
I just installed unetbootin from the community repository.
When I try to run it, I get an empty grey window (see
screenshot).


Additional info:
* package version(s)
608-1
* config and/or log files etc.
The output is as follows:

[code]
jorge@flamingo:~$ sudo unetbootin --debug
[sudo] password for jorge:
X Error: BadAccess (attempt to access private resource denied) 10
Extension: 130 (MIT-SHM)
Minor opcode: 1 (X_ShmAttach)
Resource id: 0x2200002
X Error: BadShmSeg (invalid shared segment parameter) 128
Extension: 130 (MIT-SHM)
Minor opcode: 5 (X_ShmCreatePixmap)
Resource id: 0x81
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220000b
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220000b
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220000b
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220000b
[/code]


Steps to reproduce:

Simply try to run unetbootin.

This is also being discussed in this forum thread:
https://bbs.archlinux.org/viewtopic.php?pid=1458501#p1458501

This task depends upon

Closed by  Balló György (City-busz)
Wednesday, 24 January 2018, 06:03 GMT
Reason for closing:  Won't fix
Comment by Alexander F Rødseth (trontonic) - Sunday, 21 September 2014, 09:30 GMT
Hi, thanks for reporting.

When trying to reproduce the problem on x86_64, I get no window and no error message. Will look into it.
Comment by Alexander F Rødseth (trontonic) - Friday, 26 September 2014, 09:39 GMT
What happens if you first install lxpolkit and run /usr/lib/lxpolkit/lxpolkit then start unetbootin from the menu?

Previously, unetbootin used deprectated methods for authenticating users, like gksu and gksudo. This was fixed and unetbootin now depends on polkit being properly configured.
Comment by Alexander F Rødseth (trontonic) - Friday, 26 September 2014, 09:48 GMT
Here is the background for why polkit is now required:  FS#38469 

(Or the full bug history, for interested readers: https://bugs.archlinux.org/index/proj5?do=index&project=5&string=unetbootin&status[0]=closed&order=dateopened&sort=asc&sort2=asc)
Comment by Georgios Tzanakis (geo909) - Friday, 26 September 2014, 15:56 GMT
I get exactly the same behaviour if I follow what you suggest. I tried running /usr/lib/lxpolkit/lxpolkit both with and without sudo, it's all the same.

By same behaviour, I mean, a window opens asking my username and password. This works normally, but then the same blank window appears.

Not sure if this has anything to do with it, but my applications menu is through pcmanfm. To have those, as per the pcmanfm wiki, I have
`export XDG_MENU_PREFIX="lxde-" in my .xinitrc. Not sure if this is relevant, but just in case.
Comment by Alexander F Rødseth (trontonic) - Friday, 26 September 2014, 17:23 GMT
Weirdness. Which windowmanager (or desktop environment) is this? Does it work in Xfce4? I'm unfortunately still not able to reproduce the problem.
Comment by François Chaix (fchaix) - Friday, 26 September 2014, 18:12 GMT
I have the same problem. It seems to be some sort of Qt problem, because I have the same behaviour with other software like VirtualBox when launching with sudo (or gksu and others).
Comment by Georgios Tzanakis (geo909) - Friday, 26 September 2014, 19:50 GMT
I use the i3 wm. I run all my applications from dmenu or the command line, and I never use menus; I only used the pcmanfm ones now to give feedback, cause I don't have any other access to a menu. Not that weird :)
Comment by Alexander F Rødseth (trontonic) - Wednesday, 01 October 2014, 13:06 GMT
Please test in a DE (xfce4, gnome or kde), to help pinpoint if this is windowmanager-related and/or related to polkit configuration.
Comment by Georgios Tzanakis (geo909) - Friday, 03 October 2014, 13:36 GMT
I installed xfce4, and gnome, and the problem is the same.

xfce:
- If I try to run from the menu, nothing happens.
- If I run unetbootin from the terminal, the grey window along with a message comes up (see screenshot; left terminal with two windows underneath)
- If I run unetbootin_polkit, I get an error in the terminal (see right terminal window)

gnome: I run unetbootin from activities, and I get the same grey window.

I installed xfce4 and gnome by `pacman -S xfce4 gnome` and run them from the .xinitrc by puting
`exec startxfce4`, and `exec gnome-session`, respectively, for each try. All these are as written
in the wiki.
   xfce4.png (168.8 KiB)
   gnome.png (379.2 KiB)
Comment by Alexander F Rødseth (trontonic) - Thursday, 16 October 2014, 13:17 GMT
What happens if you start xfce4 from gdm instead? I suspect that this might influence the start of the polkit agent.
Comment by Alexander F Rødseth (trontonic) - Friday, 07 November 2014, 10:37 GMT
I am still unable to reproduce the problem that involves the gray window. However, when running under xfce4 and also having started and closed a kde4 application (kate), I got a "No authentication agent found" for "unetbootin_polkit" (same as for the menu icon). Just "unetbootin" works fine.

I think this is all connected with polkit and how various windowmanagers and desktop environments does or doesn't handle the situation. Previously, I used "guisu" for handling this (same as unetbootin-git in AUR uses), but I received a bug report for that, arguing that problems with polkit were only due to misconfigured systems.

Perhaps the situation has changed, and it's time to reintroduce "guisu"? I wish it was easier to gather predictable results.
Comment by Georgios Tzanakis (geo909) - Friday, 07 November 2014, 16:09 GMT
Here real life has been a bit busy, and I don't have the time to install/configure gdm and try. I'll do that later on.
Comment by william douglas (wdouglas) - Friday, 14 November 2014, 22:31 GMT
Using xfce I see the same problem.

My auth.log contains no errors:
Nov 14 13:58:27 wdouglas polkitd[710]: Operator of unix-session:c1 successfully authenticated as unix-user:root to gain ONE-SHOT authorization for action org.archlinux.pkexec.unetbootin for unix-process:15635:140068733 [/bin/bash /usr/bin/unetbootin_polkit] (owned by unix-user:wdouglas)
Nov 14 13:58:27 wdouglas pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Nov 14 13:58:27 wdouglas pkexec[15637]: wdouglas: Executing command [USER=root] [TTY=unknown] [CWD=/home/wdouglas] [COMMAND=/usr/bin/unetbootin]

But I see the same X errors when launching the polkit helper.
Comment by Alexander F Rødseth (trontonic) - Friday, 21 November 2014, 11:07 GMT
If you install polkit-gnome and then run:

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
unetbootin_polkit

Does it work as expected?
Comment by Alexander F Rødseth (trontonic) - Monday, 01 December 2014, 12:24 GMT
Are anyone still able to reproduce the "gray window" problem? I am yet to see it here.

Running unetbootin from the menu (or unetbootin_polkit from the commandline) should work fine as long as a polkit agent is running.
Comment by Georgios Tzanakis (geo909) - Monday, 01 December 2014, 13:06 GMT
No, still grey. I installed polkit-gnome and run the command you suggested, but it still doesn't work..
Comment by Alexander F Rødseth (trontonic) - Monday, 01 December 2014, 13:31 GMT
When installing polkit-gnome and running the polkit authentication agent in the background, does unetbootin_polkit give any error messages?
Comment by Alexander F Rødseth (trontonic) - Wednesday, 03 December 2014, 12:47 GMT
Still unable to reproduce this issue. Everything works perfectly fine here. Without further information, there is nothing I can do about this issue.
Comment by Georgios Tzanakis (geo909) - Wednesday, 03 December 2014, 13:28 GMT
Sorry, I don't really have anything new to add, except maybe that I get a
"Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged."
from polkit-gnome when I first run unetbootin and I am asked for authentication..
Comment by Alexander F Rødseth (trontonic) - Wednesday, 03 December 2014, 14:06 GMT
Thank you for the additional information.
Comment by xtr (xtr) - Monday, 08 December 2014, 19:36 GMT
Hello, I'm Having the same issue after update arch linux:

Window Manager: Fluxbox 1.3.5
Polkit Installed Packages:
extra/polkit 0.112-2 [instalado]
extra/polkit-qt4 0.112-2 [instalado]

When I try to open a Qt4 Based piece of software from a different user on my limited user session (eg. login as limited user, startx and in the graphical session open a console, sustitute user su to root and then run wpa_supplicant (need root access to speak with wpa_supplicant daemon)), or another Qt4 based program I'm getting the same messages of access denied:

<tag>
root@vector-sigma ~ # wpa_gui
X Error: BadAccess (attempt to access private resource denied) 10
Extension: 130 (MIT-SHM)
Minor opcode: 1 (X_ShmAttach)
Resource id: 0x2200026
X Error: BadShmSeg (invalid shared segment parameter) 128
Extension: 130 (MIT-SHM)
Minor opcode: 5 (X_ShmCreatePixmap)
Resource id: 0x8f
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x220002c
X Error: BadAccess (attempt to access private resource denied) 10
Extension: 130 (MIT-SHM)
Minor opcode: 1 (X_ShmAttach)
Resource id: 0x194
X Error: BadShmSeg (invalid shared segment parameter) 128
Extension: 130 (MIT-SHM)
Minor opcode: 5 (X_ShmCreatePixmap)
Resource id: 0x8f
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2200033
X Error: BadPixmap (invalid Pixmap parameter) 4
Major opcode: 54 (X_FreePixmap)
Resource id: 0x2200033
X Error: BadShmSeg (invalid shared segment parameter) 128
Extension: 130 (MIT-SHM)
Minor opcode: 2 (X_ShmDetach)
Resource id: 0x2200033
</tag>

All gtk based software or non QT4 software (even qt3) runs perfectly fine from another user, so i think to reproduce should be something like: Minimalistic window manager as fluxbox, i3 or others, QT4 apps and polkit although really don't know what is generating this issue.

best regards,

xtr.
Comment by xtr (xtr) - Monday, 08 December 2014, 19:51 GMT
This is an strace attached as a ascii text file of the command wpa_gui, I'm an infraestructure guy so i really don't have the knowledge of reading it, maybe you guys can.

if I can provide anything else please just ask for it.
Comment by Alexander F Rødseth (trontonic) - Friday, 12 December 2014, 11:54 GMT
Thank you, xtr! The new information is helpful.
Comment by xtr (xtr) - Wednesday, 17 December 2014, 14:49 GMT
Hello Alex, Could I help in someway so this issue can be fixed ?

Best regards,

xtr.
Comment by xtr (xtr) - Wednesday, 17 December 2014, 18:34 GMT
doubled.
Comment by kozaki (kozaki) - Sunday, 04 January 2015, 17:31 GMT
Hi,
I meet the same symptoms described above with unetbootin (which requires special rights) and with 'Anki' (learning cards program (1) which does not require any special right).

1 - Starting unetbootin using the various methods above {unetbootin,unetbootin_polkit}, with and without [gk]sudo, user (no window) or root password fails and gives the same output as for others above.


2 - Launching Anki from the user that launched the WM via xinitrc 'exec dbus-launch i3' and Ankiit runs fine. Now and that's what I find interesting:

2' - Login as user 2 from terminal then launching Anki fails with the same output as with unetbootin:
Open an empty grey window with:

***
$ anki
X Error: BadAccess (attempt to access private resource denied) 10
Extension: 130 (MIT-SHM)
Minor opcode: 1 (X_ShmAttach)
Resource id: 0x164
X Error: BadShmSeg (invalid shared segment parameter) 128
Extension: 130 (MIT-SHM)
Minor opcode: 5 (X_ShmCreatePixmap)
Resource id: 0xae
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 62 (X_CopyArea)
Resource id: 0x2600014
***


i3-wm 4.8-3
Anki http://ankisrs.net/
unetbootin 608-1
Arch with kernel Linux 3.18.1-3-ck x86_64
Comment by Alexander F Rødseth (trontonic) - Monday, 05 January 2015, 14:55 GMT
Thank you, kozaki.

If anki fails in the same way as unetbootin (the gray window issue), perhaps we can conclude that this problem has it roots either in the toolkits used, X or the video driver?

I still haven't seen the gray window issue myself, and I have tried on several different installations.

Co-assigning to the maintainers of qt and X, just to hear if they have any input.
Comment by Georgios Tzanakis (geo909) - Monday, 05 January 2015, 16:14 GMT
Hmm.. I installed anki from the official repositories and it works perfectly fine. However unetbootin still fails.
Comment by Alexander F Rødseth (trontonic) - Wednesday, 07 January 2015, 08:40 GMT
Clearly, it is not a problem with anki. Here is the issue: even though unetbootin fails, how can we tell if it's Qt, X, upstream or packaging that is the problem?
Comment by sin3t (sin3t) - Friday, 09 January 2015, 20:35 GMT
I was having the same issue with fingerprint-gui and hp-setup. Try "export QT_X11_NO_MITSHM=1" before running app, it helped me. (Solution was found on RPI forum http://www.raspberrypi.org/forums/viewtopic.php?f=33&t=78672)
Comment by william douglas (wdouglas) - Friday, 09 January 2015, 20:49 GMT
sin3t's suggest works for me, sudo unetbooin (window blank); sudo QT_X11_NO_MITSHM=1 unetbootin (window displays correctly)
Comment by Georgios Tzanakis (geo909) - Saturday, 10 January 2015, 01:20 GMT
sin3t's suggest works for me as well!
Comment by Alexander F Rødseth (trontonic) - Tuesday, 13 January 2015, 14:36 GMT
Thank you, sin3t! And thanks for testing the solution, wdouglas.

I'll add QT_X11_NO_MITSHM=1 to the unetbootin startup scripts.
Comment by Alexander F Rødseth (trontonic) - Tuesday, 13 January 2015, 15:18 GMT
The updated unetbootin package will appear in [community] shortly (version 608-2). Please confirm that it now works as it should.
Comment by Georgios Tzanakis (geo909) - Thursday, 15 January 2015, 13:30 GMT
I have 608-2 now and it works. Thanks!
Comment by Alexander F Rødseth (trontonic) - Monday, 19 January 2015, 07:32 GMT
Great! Closing this issue.
Comment by Sardelli Tommaso (cippaciong) - Thursday, 19 November 2015, 21:48 GMT
  • Field changed: Percent Complete (100% → 0%)
I had the same error today with a similar setup: i3wm + lxpolkit.
Symptoms and error displayed are the same.
Comment by Georgios Tzanakis (geo909) - Friday, 20 November 2015, 01:32 GMT
Mine still works well after this was closed backin January...
Comment by Alexander F Rødseth (trontonic) - Friday, 20 November 2015, 23:44 GMT
Sardelli Tommaso, please check if it works if you use GDM and Xfce.
Comment by Sardelli Tommaso (cippaciong) - Sunday, 22 November 2015, 10:56 GMT
Thanks for reopening the bug, I'll give GDM and Xfce a try as soon as I can (probably next week). Another interesting point is that I have a similar setup (i3wm+lxpolkit) both on my laptop and on my desktop pc but this issue is occurring only on the desktop.
Comment by Sardelli Tommaso (cippaciong) - Friday, 04 December 2015, 15:17 GMT
Hello, I installed gdm and Gnome 3 (as it was a dependency of gdm) but I get the same error I have with i3. Should I try Xfce too?
Comment by Alexander F Rødseth (trontonic) - Sunday, 06 December 2015, 12:49 GMT
Yes please. If it works on Xfce but fails on i3 and Gnome 3, we'll have a starting point for finding out more.
Comment by Sardelli Tommaso (cippaciong) - Sunday, 06 December 2015, 13:34 GMT
You were right, it works on Xfce (I used LightDM as display manager).
Please, let me know if there is anything else I can do.

Thank you.
Comment by Martin Wallin (guzzard) - Sunday, 13 December 2015, 23:16 GMT
I also get this error both with unetbootin and tuxboot (based on unetbootin). I'm on Cinnamon with X running as non-root user. I don't use any display manager. Launch Cinnamon with startx.

Update: don't get the error today with unetbootin (have no idea what has changed?!), but i still get this error with tuxboot which is based on unetbootin.
Comment by Alexander F Rødseth (trontonic) - Monday, 14 December 2015, 21:36 GMT
Sardelli Tommaso, thanks for checking.

Now that we know it works on Xfce + LightDM (or GDM), but not on Cinnamon or i3, it's a start.

Could the difference be if a polkit agent is running or not? Could lxpolkit be the exception?

More testing is needed, and it's not a given that the root of the problem is with this package.
Comment by Sardelli Tommaso (cippaciong) - Monday, 01 February 2016, 11:26 GMT
Hello, I come back with (I hope) interesting news.
Today I launched unetbootin on my laptop (which wasn't affected by the problem described above until now) and had the infamous blank window.
In the past weeks I noticed at a certain point, that the blank window was not in what we may call a "freeze" state, actually it was probably working just fine but every GUI element had the same color (text, background, buttons etc). I came to this conclusion when I opened two windows side by side (one with pkexec, the other as a normal user which displays correctly) and, using the latter as a reference, I placed the mouse pointer where I knew there was a GUI element. As a result, the relative tooltips popped out!

So, here is what I did today:
suspecting that the problem could be just related to gtk/qt themes rather than a real problem with the application, I tried to run qtconfig-qt4 preceded by pkexec, the result was "Failed to open display" as you might expect.
After some digging in the forum I came out with a custom polkit policy which I put in /usr/share/polkit-1/actions, (you can see it here: http://pastie.org/10703974). In this way I was able to run pkexec --disable-internal-agent "/usr/bin/qtconfig-qt4", set the GUI Style to "Cleanlooks", save/exit.
With this change I was finally able to run unetbootin_pkexec. :)
I'm using it right now and it's working flawlessly so far.
Comment by Alexander F Rødseth (trontonic) - Wednesday, 03 February 2016, 22:01 GMT
Sardelli Tommaso, That is both interesting and impressive! Nicely done.

Felix Yan, Perhaps the /usr/share/polkit-1/actions file could be placed in the qt4 package?
Comment by Felix Yan (felixonmars) - Thursday, 04 February 2016, 01:43 GMT
I would try to see how upstream thinks of this first, thanks.
Comment by Alexander F Rødseth (trontonic) - Monday, 08 February 2016, 19:09 GMT
That's fine. I think this is a qt4 and/or polkit issue of some sort. Unassigning myself. Please re-assign if you think the issue belongs to unetbootin.
Comment by Babken Vardanyan (axper) - Monday, 12 June 2017, 05:26 GMT
Sardelli Tommaso can you please rehost http://pastie.org/10703974 , the link is down
Comment by dx (dx) - Monday, 16 October 2017, 16:41 GMT
Any of these work for me:

sudo QT_X11_NO_MITSHM=1 unetbootin.elf
sudo QT_GRAPHICSSYSTEM=native unetbootin.elf
su -c 'QT_X11_NO_MITSHM=1 unetbootin.elf'
su -c 'QT_GRAPHICSSYSTEM=native unetbootin.elf'

pkexec, however, doesn't work. It even makes things worse by clearing the environment. I don't know what was in that policy file in the expired pastie, I don't know if that would help.

Main problem here is the wrapper script, imo. It attempts to set QT_X11_NO_MITSHM=1, and if pkexec is installed, it calls it even if running the wrapper script as root. That clears QT_X11_NO_MITSHM. I guess the addition of that variable helped for people who didn't have pkexec installed.

I'm not sure how to make pkexec pass that variable, "pkexec VAR=1 app" tries to execute VAR=1, and "pkexec env VAR=1 app" fails to connect to X at all.

While this issue is something that affects all qt4 apps run as root, unetbootin is a relatively rare case (if not unique) of a qt4 app that requires this, and arch's wrapper script is making the situation worse than just launching unetbootin.elf (which shows a message telling the user to re-run as root with QT_X11_NO_MITSHM=1)

So the attached patch against the wrapper script adds "$(id -u) -ne 0" before trying pkexec. It fixes "sudo unetbootin" and "su -c unetbootin". Trying to run it as an unprivileged user (and trying to use pkexec) remains broken, but it's an improvement to have it working at all imo.
Comment by Balló György (City-busz) - Wednesday, 24 January 2018, 06:03 GMT
unetbootin has been moved into AUR:
https://aur.archlinux.org/packages/unetbootin

Since no other Qt4 apps using pkexec, I'm closing this task.

Loading...