Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41938 - [popt] don't "--disable-static" when configuring

Attached to Project: Arch Linux
Opened by Steven Honeyman (stevenhoneyman) - Thursday, 11 September 2014, 19:29 GMT
Last edited by Eric Belanger (Snowman) - Monday, 15 September 2014, 02:41 GMT
Task Type General Gripe
Category Packages: Core
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The PKGBUILD disables a static library from being compiled for some reason (default without any parameters makes both). As popt is needed for cryptsetup, rsync, and other tools that may be needed to rescue/recover a "broken" system, someone might want to compile them statically in case glibc is broken.

Additional info:
* don't forget options=("staticlibs")
* total installed size for both is a tiny 157kb, so it isn't going to waste much bandwidth or space :)
This task depends upon

Closed by  Eric Belanger (Snowman)
Monday, 15 September 2014, 02:41 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Since we remove the static library by default, I've removed the option. If you want a popt with static libs, recompile it with staticlibs set in makepkg.conf
Comment by Allan McRae (Allan) - Thursday, 11 September 2014, 21:30 GMT
If glibc is broken, how will you boot to use these tool without using a rescue disk?
Comment by Steven Honeyman (stevenhoneyman) - Thursday, 11 September 2014, 21:37 GMT
that was a hypothetical situation by the way, my system is fine :)

linux /boot/vmlinuz-linux root=/dev/sda2 init=/bin/dash

that should do the trick (it's my own kernel, and static compiled shell)
an initramfs with just a static busybox and a few scripts also works
Comment by Doug Newgard (Scimmia) - Monday, 15 September 2014, 02:14 GMT
Arch is removing static libs and static linking wherever possible. This seems counterproductive. When nothing else in the repos is statically linked, there would be no benefit here.

Loading...