Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41923 - [opencv] Add VTK support

Attached to Project: Arch Linux
Opened by James Duley (parched) - Wednesday, 10 September 2014, 22:38 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 11 October 2018, 05:50 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: VTK support was added in the form of the viz module in 2.4.9. Consider adding vtk as a normal dep or as both a make and optional dep.


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 11 October 2018, 05:50 GMT
Reason for closing:  Fixed
Comment by Ray Rashif (schivmeister) - Tuesday, 11 November 2014, 10:41 GMT
Due to lack of user testing and feedback I had prematurely added the support for this. The python interface is not affected, but otherwise vtk cannot be an optdep. Moreover, there is a qt issue discussed at  FS#42715 . I am reopening this and keeping this open until I can sort it out (I will have to bring in vtk to extra to begin with).
Comment by Johannes Jordan (FoPref) - Tuesday, 11 November 2014, 14:33 GMT
Please remove the vtk dependency. It is not o.k. for a package in [extra] to depend on [community], and especially not as the package does not advertise this. It causes problems :-(

Anyway thank you for your work on the package and keeping OpenCV up-to-date!
Comment by Ray Rashif (schivmeister) - Tuesday, 11 November 2014, 17:52 GMT
Absolutely, it was never OK to depend on anything outside extra, _except_ for make and optdeds. This one just doesn't work as an optdep. You can build projects fine but they won't run.
Comment by Johannes Jordan (FoPref) - Wednesday, 12 November 2014, 23:31 GMT
Actually, I came here deliberately because my project would not build without installing VTK. It would not link.
Comment by Ray Rashif (schivmeister) - Thursday, 13 November 2014, 08:37 GMT
Right, VTK has now been removed and your project should compile, link and run as expected. Please report back if that's not the case, thanks.

To anyone who's interested in having VTK support: VTK in [community] will probably be dropped by the maintainer due to v5's maintenance burden. If I bring in v6, I'll have to bring in one or two other packages (namely gdal).

Normally, just one FR is enough for me to go the extra mile and add the support for something. But if this turns out to be more work than it's worth, I'll take a look at the votes here (presently none) and usage data for opencv as well as vtk/mayavi in pkgstats.
Comment by Johannes Jordan (FoPref) - Thursday, 13 November 2014, 13:59 GMT
So I tested the new package after de-installing vtk. Everything works as expected! Thanks for your efforts!

I think until upstream fixes this to work as an optional dependency, AUR is the right place for custom builds with GDAL/VTK etc.
Comment by André (aandre) - Friday, 28 September 2018, 22:27 GMT
Four years have passed since the task was opened. We have now OpenCV 3.4 and VTK 8.1, so the issue holding back an (optional) dependency on VTK might be fixed.
Comment by Johannes Jordan (FoPref) - Sunday, 07 October 2018, 01:10 GMT
OpenCV projects do not link anymore if VTK is not installed.
Comment by Antonio Rojas (arojas) - Sunday, 07 October 2018, 07:15 GMT
Every single package in our repos builds fine without vtk. Please be more specific

Loading...