Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#41918 - [mesa] OpenGL broken

Attached to Project: Arch Linux
Opened by Nick Overdijk (Nickert) - Wednesday, 10 September 2014, 18:25 GMT
Last edited by Laurent Carlier (lordheavy) - Wednesday, 10 September 2014, 22:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Evangelos Foutras (foutrelis)
Laurent Carlier (lordheavy)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
OpenGL seems broken on my arch since a couple of days. First discovered by using Qt Creator (see #41886) but today discovered it affects all programs using OpenGL.

Additional info:
I just ran pacman -Syu, so everything is up to date.
My friend running the (unofficial) catalyst driver doesn't have any issues.
* package version(s)
* config and/or log files etc.

Steps to reproduce:
Launching any program that uses OpenGL leads to the following error:
LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb

For example

nick@fusrodah:~$ glxgears
LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb
✗ - status code 1
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Wednesday, 10 September 2014, 22:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa 10.2.7-3
Comment by Nick Overdijk (Nickert) - Wednesday, 10 September 2014, 18:30 GMT
People from the other ticket gave the following errors:
"intel_do_flush_locked failed: Invalid argument"
"qtcreator-bin: r200_maos_arrays.c :101 : r200EmitArrays: l'assertion « 0 » a échoué."
Comment by Laurent Carlier (lordheavy) - Wednesday, 10 September 2014, 19:55 GMT
what is your cpu?
Comment by Nick Overdijk (Nickert) - Wednesday, 10 September 2014, 20:25 GMT
Intel i7 930
Comment by Evangelos Foutras (foutrelis) - Wednesday, 10 September 2014, 21:13 GMT
Please test if mesa 10.2.7-3 from [testing] fixes this issue.
Comment by Nick Overdijk (Nickert) - Wednesday, 10 September 2014, 21:58 GMT
I don't have mesa in my list (yet?):

nick@fusrodah:~$ sudo pacman -Syu
:: Synchronizing package databases...
testing is up to date
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Packages (27): archlinux-keyring-20140908-1 binutils-2.24-7 ca-certificates-20140325-2 ca-certificates-cacert-20140824-1 ca-certificates-mozilla-3.17-3
ca-certificates-utils-20140325-2 dialog-1:1.2_20140908-1 fluidsynth-1.1.6-4 gcc-4.9.1-2 gcc-libs-4.9.1-2 gettext-0.19.2-2 glibc-2.20-1
graphviz-2.38.0-2 guile-2.0.11-2 iproute2-3.16.0-1 libevdev-1.3-1 libgpg-error-1.14-1 libtirpc-0.2.5-1 libunistring-0.9.4-1 linux-api-headers-3.16.2-1
man-pages-3.72-1 nspr-4.10.7-1 nss-3.17-3 openresolv-3.5.7-2 thin-provisioning-tools-0.4.1-1 valgrind-3.9.0-7 zsh-5.0.6-1

Total Download Size: 65.05 MiB
Comment by Evangelos Foutras (foutrelis) - Wednesday, 10 September 2014, 22:03 GMT
It looks like your mirror hasn't synced yet. You can try another mirror or wait a bit more for your mirror to sync.
Comment by Nick Overdijk (Nickert) - Wednesday, 10 September 2014, 22:08 GMT
I'll check it tomorrow. Thanks for your help.
Comment by Nick Overdijk (Nickert) - Wednesday, 10 September 2014, 22:15 GMT
Yup, that fixes it.

Loading...